Predefined policies not doing their job

Hello Comodo world!

I have downloaded the latest version of Comodo Firewall from the website for a Windows Vista 64-bit machine. The issue I’m about to describe has happened on Vista 32-bit and XP Pro 32-bit machines as well.
When I add my own custom predefined security policy in the firewall, all seems good when I save it into the firewall software. However, when I am prompted to allow or block a program that is trying to make a connection, my predefined policy does not show up in the drop down menu. As a test, I’ve modified the factory “Outgoing Only” policy that comes with Comodo Firewall. I simplly added another block property to it to test if my change would be saved. When I modified it and saved it, it stopped showing up in the drop down menu with the new prompts. This is very strange, does anyone have any suggestions? I’ve tried uninstalling and reinstalling the software a few times and no dice. Also, I’ve ensured that I have downloaded the 64-bit compatible version of Comodo Firewall for Windows Vista. Also, after this problem, I tried mapping the process to a different predefined policy. Then, I would go in to the Network Security Policy screen and manually change it to the predefined policy I created. Strangely, all of the policies show up normally in the Network Security Policy screen when you edit policies for any application. However, when I assign the policy to the application I was testing with, I will receive prompts as if Comodo has never seen this program before. Please help! I have no idea what to do next. Is this simply a bug?

While you’re waiting for one of the experts, just wanted to say that modifying the preset “outgoing only” policy DID work for me on my XP Home system. So I don’t think it’s a bug. I assume you’re new to Comodo, so are you sure when you make changes you are remembering to click the APPLY on all the screens as you exit out? I know on occasions I think I have done so only to realize I have not and have to enter my changes again. If you APPLY back to exit off each screen (rather than click the X to close the screen), the rules/modifications always “register” for me OK.