Possible file damage from Comodo rescue disk

I have used the Comodo free Internet security package for a couple of years now and I am happy with it. Based on that, I tried the Comodo rescue disk, ver. 2.0.261647.1. I made a CD from the ISO and when I booted with it, and started a scan, it reported an unspecified threat, then disappeared from the screen.

The app did not crash, the scanning program just stopped. Later, on rebooting into Windows, I noticed that four of my main Windows 7 directories were erased or damaged (Program Files, Program Files (x86), Program Data, and a directory I use for Legacy apps. There was no damage to my User directory, which is amazing.

They contained many important apps. Comodo rescue disk had created a directory on my C:\ drive called cce_linux with the following sub-directories: coredump, log, quarantine and scanners.

I have never liked the idea of using Linux on a Windows system and I am convinced that Comodo rescue disk caused the damage. I have managed to repair most of the damage and my system is almost back to normal. However, I no longer trust the rescue disk.

The damage could have come from me fiddling with the Linux setup in an attempt to get a wireless connection established from the rescue disk, but I think Comodo mistook something on my disk as a threat and tried to do something. I just don’t think it is a good idea to combine a Linux OS with Windows.

I’m wondering if anyone has encountered such file damage while using the rescue disk.

Were the directories actually erased or were the permissions on them changed so you could not access them?

I have seen the latter (which is fixable) on my machine.

They were erased, probably written over. That’s why I don’t like Linux apps interfacing with windoze.

I have managed to recover most of them but I had to re-install a lot of them. Some of them responded to a repair re-install.

I noticed something that is really odd in Win 7 with compatibility issues. Some of the apps I retrieved using a low level disk editor but windows would no run them, claiming they were not compatible. The same file was running perfectly on Windows before, but after being erased, something must have gotten messed up in the registry.

Microsoft is really bad with that. Their ‘wizards’ rely on the registry and on ‘inf’ files. If either are damaged, or an inf file is missing, the wizard suddenly becomes a ‘dummy’. It’s the same with compatibility issues, their compatibility wizard could not solve the problem, meaning there is something else in the registry, or elsewhere, that tells windoze that a file is not compatible, even if it is compatible.

OK different issue then.

Very sorry you have had this problem

Please report as a bug if you can document it.

Best wishes