Ports only open every other reboot/log off/close-start sequence

I noticed the following bug (and tested it).

I have two ports open in Comodo for E Mule (in the Global rules of Network Policy). Part of the time Comodo doesn’t open them. E Mule will report then that the connection to the E Donkey and Kademlia network is firewalled.

Testing showed that every other reboot the ports are open. So, when the ports are closed just reboot and the ports will be open. When rebooting again the ports will be closed… reboot and the ports will be open again… (Note that the ports on the router are always open).

The same thing applies for logging of and logging back in on my Vista user account. It also applies to shutting down and then starting the computer.

Temporarily disabling AVG antivirus and Peer Guardian made not difference.

Edit. Exiting and starting the program has the same effect.Ramancars found out that closing and exiting the program helped with a similar problem with Comodo forgetting the Defense + rules every other time.

I have the same problem with DC++ ports… Download and search doesn’t work. :frowning: Comodo doesn’t open them even if I set the rule to do so.

Try exiting and starting Comodo. For me that helps to get E Mule listening to the two ports. Otherwise try a reboot or logging out and in your user account.

that doesn’t help. :frowning:
Any other ideas… instead of uninstalling Comodo? :smiley:

To see if it is a firewall setting problem please set the firewall to allow all.
If the DC++ problems are still there then it should be a compatibility problem.
Do you have any other security software installed (like antivirus, spyware detectors and such?

Check antispyware, anti virus and other security programs.

I was testing uTorrent for a housemate. The port test of the site showed no traffic. It turned out that Peer Guardian was blocking the uTorrent site.

Testing Limewire for another housemate showed Spy Sweeper messing. I turned the background process of Spy Sweeper (wrssdk) off and it worked. Turning it back on and Limewire still worked…

Well… very strange but I’ve checked everything and nothing seems to interfere with DC++. I have Avira AntiVir as antivirus.
My DC++ worked very well till I installed Comodo. Then downloads and search function stopped working.

I’ve checked “Allow all” under firewall but nothing… the problem is still there. :frowning:

Follow thsi tutorial on how to set the rules in Comodo: https://forums.comodo.com/faq_for_comodo_firewall/tutorials_a_compiled_resource-t6167.0.html;msg45504#msg45504 . Make sure to put the rules on top of the basic block rul “Block all incoming request”. That is crucial.

I am sure the IP reversing alternately is the cause…

EricJH, I’ve followed the tutorial… I"ve set the rules under ApexDC++ and also under Global rules and they are above all other rules. Still not working. :frowning: I"ve also disabled “Do protocol analysis”)

Glass, what should I do in this case? Can you explain me in details, please? Thank you!

When I start my computer, I open Comodo and see for a standard UDP rule that I have created under any application.
If the IP is inverted from what it should be, I right click on Comodo icon in the system tray and exit. Give a couple of minutes for it to unload completely and restart Comodo from Start-Programs.

Works for me each time. And hope it is corrected in next version!

There was a different compatibility problem with Avira (please reproduce that too).
If we can confirim this to be another kind of issue it will be fixed though.

So the only thing I could suggest to you is a generic thoubleshooting list… :frowning:
If there is a compatibility problem then whe should exclude the chance of
CPF rules interfering with DC++.

So the first thing to do should be to set the firewall and defense+ to allow all.

If that doesn’t work the next step should be should be disabling Avira

If DC++ still doesn’t work the last step should be making a system restore point and a complete uninstallation of Avira.

This could provide enough info to eventually fix the problem with a workaround
or a future beta update.

I cannot comment on Avira as I don’t use it. I am using AVG anti virus that is free as well and throughout the years has never showed to be a troublemaker. It sits without problems besides other anti virus programs. Another advantage is that it scans emails. In tests Avira and AVG are usually in the same league.

When I stop and start the firewall to let E Mule work I also have to stop and start E Mule as well. Otherwise one of the two ports remains closed. May be this is of help.

Thank you for your help… the problem seems to be solved now. :BNC

Here’s what I’ve done… I’ve tried everything you suggested and seemed not to work, then I’ve uninstalled Avira and after restart, I’ve opened ApexDC++. Suddenly, Windows Firewall popped up saying: “ApexDC++ was blocked for your safety…: Keep Blocking, Unblock”. I was astonished that I knew Windows Firewall was disabled. I choose Unblock and now my ApexDC++ works as it should. (with Avira enabled also).
I went to Control Panel-> Security Center-> Windows firewall and I turned it off… My bad… I was sure it is turned off. :frowning: Now it is strange it didn’t said anything till I uninstalled Avira.

Anyway, now everything is good. Thank you all for suggestions! (V)

Glad you solved the issue :).

This could mean that the beta solved the issues with avira.
Could you test this?

The scan from the context menu (right click scan) doesn't work properly any more. Avira now incorrectly reports 0 files and 0 folders were scanned.

It’s working perfectly. I’ve tested with 3 different folders and files. :slight_smile:

Now the only problem is that sometimes (during the first half an hour after connecting to the internet) I receive IP conflict, that I never received before. Perhaps Comodo blocks something. ???

May be you are the vicitim of the network address reversal bug: https://forums.comodo.com/32_bit_bug_reports/ips_in_rules_get_reversed_alternately_307208-t11580.0.html .

You mean the yellow triangle thingy with an exclamation point?
I saw that sometimes on a pc without cpf I never found a solution to that but if you are not affected by the ip reversal bug you could try to create an item on “my network” in firewall\common tasks and then you could use the Firewall stealth Configuration wizard in firewall\common tasks to make your private lan ip range (eg. netmask trusted using “I would like to be completely visible from within a trusted network” option.