Portforwarding issues with several programs

I’ve been trying to portforward my Plex Server and my Deluge but I just can’t seem to get it to work.
It’s not the first time I forward something, my utorrent is running just fine for example but these just aren’t working.

I’m running behind a DD=WRT router SVN revision 12548M NEWD Eko so I first just forwarded the single port for both apps as TCP/UDP for Plex and TCP for Deluge (tried TCP/UDP for deluge as well but I never use UDP and it didn’t work anyway so that doesn’t help either). I even tried enabling UPnP, which did recognize my apps but still didn’t forward them so into Comodo I went.

What I did so far for my Plex Server is fairly simple, I added a program rule Allow TCP or UDP in/out from MAC to all MAC where source port is all and destination port is the port I set Plex to.
That didn’t work, so I added a global rule and added it to the top allow list to Allow TCP or UDP in/out from MAC to all MAC where source port is All and destination port is the port I set it to.
That didn’t work either.

As for my deluge.
I pretty much copied my working utorrent rules and linked them to deluge allowing the different destination port.

The app rules set in this order are:

Allow TCP or UDP In for All Sources ad, All Destination ads, Source port series 1025 to 65535 and destination port the one I set my deluge to

Allow TCP Out Source ad and Destination ads Any, Source port 1025 to 65355 and Destination port 1025 to 65355 as well. (come to think of it the Source Port should be my locally set port only but I think I just ■■■■■■■ up with that making the utorrent rule, I don’t think it should be much of a bother right?).

Another one exactly the same as the above but for UDP Out

Ask TCP OUT Source ad Any, Destination ad any, Source Port 1025 to 65535 and Destination Port A set of Ports, HTTP ports

Block IP In/Out, Log, source all, Destination All, IP All

That didn’t work while it does for my utorrent (go figure).

So I tried adding a global rule for this as well which is the same as the one I did for my Plex but with a different port ofcourse.

That didn’t work either.

I don’t have any special global rules. just the default ICMP blocks and 2 allows for my home networks.

I’m kind of running out of ideas, can someone give me a hand please? Neither Deluge nor Plex Server are able to connect.


Deluge seems to have magically started working all of a sudden, didn’t change a thing but no more “no incomming connections” error shrugs. Didn’t change a thing, UPnP is still turned off, just have the ports forwarded in comodo and the router just like I did an hour ago.
I’m still stuck with Plex Server though, that still doesn’t connect.

Check the firewall logs to see if its blocking something. Your rules don’t make sense to me, but I’m not that familiar with Plex servers and Deluge.

The app rules I mentioned are pretty much ripped off of the uTorrent forum so I assume those are good. Plus, Deluge magically started working after a bit.

Plex Server unfortunately does not. Plex Server is a program that scans all your media and links everything with artwork etc. and then you can use a Plex Client on, say, a phone or a media center to watch or listen to your stuff anywhere you want.
So what it needs to do is connect TCP and UDP on 1 port just like, say, an FTP server or something (nothing better comes to mind).

I don’t see any obvious blocks in my firewall btw, just those from the rules i defined myself…
It’s going wrong somewhere though because it’s unable to connect out while it is able to log into my account on the same webinterface (so it does have connection it just doesn’t allow the port).
I just tried to DMZ my entire IP of the machine Plex is running on and that didn’t work either so it’s not my router, it has to be comodo.

A quick google shows that Plex Media Server requires TCP 32400 and utilizes several other protocols, UPnP, Bonjour, etc.

Full Port list:
TCP 32400 - Plex Media Server
UDP 1900 - Plex DLNA server(UPnP)
TCP 3005 - Plex remote control via Plex Companion
UDP 5353 - Bonjour Network Discovery
TCP 8324 - Plex for Roku via Plex Companion
UDP 32410, 32412-32414 - GDM Network Discovery
TCP 32469 - Plex DLNA server

I as I said checking the firewall log would help show part of the commuication is being blocked.