Pop up the actual IP a program is trying to connect to, not my router address.

I searched the forums for my question and checked the manual, but did not find an answer.
My old PC had Vista with Comodo while connected to a router. When a program would try to connect to the Internet, Comodo would pop up giving me an actual IP like or something. Now with my new Windows 7 PC and the same router, it shows that all programs are trying to connect to my router address, How do I get Comodo to show the actual IP again? Even the Firewall Events lists
Sorry if this has been covered before. Thanks!

Can you post some details of your firewall application rules, firewall logs and the settings you are using. You can attach screen shots via ‘additional options’

My DNS service was disabled. I disabled this service earlier reading a Windows 7 tips and tricks article. Restarting the service resolved my issue. Comodo was acting like it was supposed to. The program was attempting to connect to my router to resolve the address. Thanks!