Please help setup Comodo for Vuze

I first installed Vuze about a week ago, messed with it a little bit and just ended up getting far too ■■■■■■ off and forgetting about it. So now in the past couple of days I finally figured out how to download torrents, but I’m still pretty stupid about it all.

I’ve just got it set as a trusted application cause I have no fing idea how to set it up properly, like the title says, I’m a fing ■■■■■■.

I’ve tried this:

And it didn’t work so I just set it back as trusted.

Before, I could download up to like 30 kb/s but usually around like 10 but also down to like 3, but it wasn’t uploading to seed or whatever.

So now after I tried those rules in that thread and went back to trusted, it’s uploading at like 20 kb/s and downloading at like 3-10 kb/s. It’s slow.

I’m not really good with handling stress and I end up just getting very ■■■■■■ off and smashing things so if you could help a fing ■■■■■■ on fing ■■■■■■ level speech that would be preferable.

Windows XP SP2 32 bit, AT&T/Yahoo DSL - Motorola 2210-02-1002 Modem, Newest Comodo FP3, Avira premium, blah blah blah.

I assume I have a dynamic IP address, I have no idea if it’s a modem/router, or just a modem, I’m a f***ing ■■■■■■.

I have yellow smiley faces on the download and seed/upload torrent. It says

“means that the tracker is ok, you’re connected to peers, but you don’t have any remote connection. You may have a NAT problem if your torrents stay on yellow status all the time.”

I have no idea if they were on yellow status when I was getting like 30 kb/s download speed because, being a f***ing ■■■■■■, I couldn’t find the smiley faces. I found them today.

I’ve also read a bit of this thread

But there’s just too much ■■■■ to read and it says it’s for utorrent.

I actually think I’ve made some progress. Following the advice in this thread:

I had to use a non-standard port (standard = 49152-65534) that was unassigned. I noticed in my firewall events that a port was blocking UDP, I took note of the port number and tried it out, applied the rules from that thread and tested the port with Vuze’s NAT/Firewall test and it worked.

I’m looking at 3 green smiley faces, 1 yellow and 1 blue. Before it was just 2 yelllow and the rest were blue.