Please help me give CFW a 3rd chance (no internet connection at all)

So I really want to give Comodo Firewall a chance but I’ve never been able to get it to work, I’ve tried once a long time ago maybe 6-10 months ago with the same problem then that I have now, I tried installing it yesterday, but had to uninstall it. This time (and will be the last time) I’m going to try installing it again but hopefully have a mod or someone to talk to and help me troubleshoot this and hopefully get it to work.

My problem is I do a clean install of whatever the latest is this case 5.4 it installs and I then reboot, after that there is no connection what so ever, none of the browsers work, can’t ping my router, can’t connect to my router even, so there is definitely something with the settings somewhere. I’ve followed all the guides on here to the best of my ability with no fix, and its a pain in the ■■■ to troubleshoot my self since its my only computer and when its installed I have no connection to look things up on google/comodo forums, even disabling firewall/defense+ doesn’t bring back a connection, I have to uninstall the thing completely to get online again.

I was able to borrow a laptop for today so now I have something to use when my desktop has CFW installed with no connection, So if someone is willing to help me through this and wait in standby mode while I reinstall CFW again then help me troubleshoot this thing I’ll transfer 1 million cool dollars to you’re PayPal account. ;D

There was a problem with the release of v5.4 when ARP cache protection was enabled some users could not connect to the web. Disabling ARP cache protection worked around it and gave back internet access

Yesterday a bug fix was released. You can update using the updater or download the installer from COMODO Internet Security 5.4.189822.1355 Released!.

In case you want to keep your settings export them from Manage My Configurations and import them back after installing (you can import them before rebooting if you like).

I made sure ARP cache was disabled, it didn’t fix anything.

Does the problem persist with the latest version? When that doesn’t help try the following.

Best thing to do to make sure that there are no left overs of previously uninstalled security programs around. Not all uninstallers do a proper job. And left over applications, drivers or services can cause all sort of “interesting effects”.

Following are two of my tutorials to make sure there are no more left overs.

Use existing removal tools

Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

For a more technical hands on approach:

We are gonna take a look to see if there are some old drivers of your previously uninstalled security programs are still around. First run "set devmgr_show_nonpresent_devices=1’ without the quotes from the command prompt.

Then go to Device Manager → View → show hidden devices → now look under Non Plug and Play drivers → when you see a driver that belongs to your previous security programs click right → uninstall —> reboot your computer. You need to Google the driver’s names to see to what programs they belong to. You don’t want to uninstall Microsoft/Windows related drivers of course; some Microsoft drivers may show up as non active please don’t uninstall them. It is best to make a system restore point before this of course.

When the problem persists make sure there are no auto starts from your previous security programs. Download Autoruns and run it.

This program finds about all auto starts in Windows. This tool can therefore seriously damage Windows when not handled properly. After starting push Escape and go to Options and choose to hide Windows and Microsoft entries, to include empty locations and then push F5 to refresh.

Now check all entries to see if there are references to your previous security program. When you find them untick them. After unticking reboot your computer and see what happens.

Going to give all that a try, give me a few minutes and I’ll report back.

I’m baffled, I did some registry hunting for anything left over and so I did, removed then proceeded to install CFW, it now works, I can’t believe it was something this simple. So it seems my old firewall was the cause.

We could have sufficed with the unofficial removal tool here. For those who need this tool it can be found in Uninstaller Tool for Comodo Products.

I used Revo Uninstaller free ver. Download Revo Uninstaller Freeware - Free and Full Download to sucessfully uninstall and remove all traces of Comodo ver 4 on my XP SP3 OS in the past. I have not tried it on Comodo ver. 5 yet. Run it with max. clean settings.

Anyone try this on Win 7 x64 ver. on Comodo ver. 5? Come to think of it, I don’t know if there is a x64 ver. of Revo Uninstaller?

Just some useless toadying from me! ;D

I read this thread with some dismay. I was just looking through various settings on Comodo, having used it for a fairly long time. I was just reflecting what an amazing security programme this is, and how much really good development work has been done on it, both for security and ease of use. So I am glad you gave it a chance and I for one am extremely happy with it as a security system. Having tried several others over the years I finally have settled with Comodo for the long haul.

I’m glad too, It does seem really great from the whole day I’ve been using it so far, not sure what the people are smoking when they say its a resource hog because it is quite low IMO, but then again I just use the Firewall w/ Defense+, so maybe the AV brings that up I dunno. Another thing I was worried about was how obtrusive I’ve heard people say it can be, again I think that’s overblown some, but can depend on settings I guess, though I have noticed some obtrusiveness, like trying to start Starcraft 2 and getting errors about memory buffer overflows and memory violations, took some tweaking to getting it to work, hope I don’t have to do that with everything I want to run.

My only complaint thus far is probably some parts of the interface, most if it is fine, but things like “View Active Connection” could use an overhaul, perhaps add some filters for the user, and I’m a sucker for graphs, something like what Sygate’s Firewall uses, my 2 cents anyway.

All in all I’ll be sticking with this for quite awhile me thinks, great product Comodo guys, thumbs up.

I have had a couple of instances where Comodo has grabbed about 90% of the PC and held it for maybe a minute. However this has just been in the last few days/weeks, and I am still trying to find a constant action that may cause it.

Other than that, it has not bothered me as a resource hog.

I agree that there are parts that could be improved on the interface side, but they have been already IMO. The thing has been turned into a suite and that was a HUGE leap. Many user complaints and suggestions have been heard. Pretty much these days I just let the thing get on with it so much, and have so little (no) trouble with nasties on my Webbed PC, that the interface and I hardly collide. :slight_smile:

All this should get me free upgrades I reckon! ;D