Please Help - Gonna Snatch My Hair OUT!

I successfully removed viruses from my friend’s laptop, and was able to connect to the Internet for three days afterward.

Two days ago I connected to a local wireless network, and now I cannot connect to cable/wireless AT ALL! I tried ComboFix, which has always worked, called BrightHouse, to no avail. I cannot get online with IE or Firefox.

BrightHouse can communicate with the modem with no problem. They say it is not communicating with the computer. My friend said her USB did not work, but with NO ethernet port on her laptop I have only ever connected via USB. So why now I cannot???

I need to return her computer by Wednesday. Can someone please help before there is a bald-headed RedHead in these forums?

Can anybody help?

i have never heard of connecting to the internet Via a USB port unless you were using a USB wireless card of sorts. so im assuming your connecting to your router via wireless. try unplugging your router and then plugging it back in after 8 seconds to a minute. also try the almighty “repair” option in the connections part of your control panel.

Can you show us the Firewall logs and Global Rules?

Well here is a picture of a USB Network Connection and its not a wireless network card

Also try this link if all things fail: ( i checked it against comodo’s list Its Safe) only works on XP

[attachment deleted by admin]

Sorry guys, I’ve been out of town for a few days. I will do what all of you sugggested! And Vundo was the virus the laptop. Ran VundoFix.

Additional info: Judy picked up the laptop. I told her it would not connect. She said it was because she had to enter her passcode. Guess what? It did not connect. So I have the laptop back!

I downloaded the Atheros drivers for her computer, uninstalled Firefox and reinstalled. If I open the Wireless Connection, it says the Atheros is “wireless, shared”. It is sending and receiving packets for sure, but I still cannot access a webpage. I opened/closed Network Connections, and verified that packets are being sent & received.

It has to be a simple resolution, I just don’t know what it is. Avast shows clean, Malwarebytes, SuperAntispyware shows clean. The VUNDO virus was cleaned off.

I will post the Atheros diagnostics if that will help.

Right now my connection status is:

Address Type: Assigned by DHCP

I opened command prompt and did “ipconfig”.

Ethernet adapter LAC:
Media state: media disconnnected

Ethernet adapter WNC:
Connection - specific DNS suffix:
IP Address:
Default Gateway:

Pinged with 32 bytes of data:
Statistics: Sent = 4, Received = 4, Lost = 0

Could you show us screenshot of the Firewall logs and the Global Rules?

Eric, since it’s not my laptop I don’t have Comodo installed on there. Judy is not computer savvy at all and I don’t think she’d be good with it. Can I pull a log report from Windows Firewall? It’s actually disabled at the moment.

I can temporarily install it if I need to.

Connection - specific DNS suffix: sounds a little flaky

I’ve never seen that option turned on except for a very large corporate address space

also try running lsp-fix its possible your lsp is corrupted