Anyone using playon? If so are you having any issues connecting to hulu and if so how did you resolve? CIS is blocking the stream somehow and I’ve given the mediaserver full access as far as I can tell. When I uninstalled comodo I was able to connect. I believe it started with the last release but I cant figure out what setting might be blocking. Thanks.

I’m having the same problem. Comodo is running on a Vista machine. If I uninstall Comodo, PlayOn works. Otherwise I get a corrupt data error almost every time I access a video with the PS3.

I would like to say that I’m having the same issue. The developer of PlayOn has investigated the issue and has come to the conclusion that it’s COMODO that’s causing the problem- not their software. Any idea when a fix will be put out to resolve the issue?


Same problem here. I hope there is a fix or that Comodo will communicate with Playon developers to develope a workaround.

Hi all, looking at Playon’s forums, it would appear that a great many people are having problems and with many different security configurations, from no firewall to any kind you can think of. Unfortunately, the support there seems to only have one answer, allow full access to the main playon executable for both in and outbound communication.

Unfortunately, I don’t have access to their content from my country, so I can’t test it. You could try making MediaMallServer.exe a trusted application, see if it helps…

I believe I did set the application as trusted when it first prompted me and I still had the same issues. For now, I’m using another free firewall product until the issue is resolved. Admittedly I do prefer Comodo over the current product I’m using. All the other highly rated firewalls either don’t work with x64 OS or they are buggy as all get-out and don’t deserve even a cent for their ■■■■■■ product. Hey, if I am able to send you the Playon executable would you be able to test it out? I suppose I could send it via Google mail since the installer is so large.
In order to reproduce the issue, you need to use a media device to connect to the computer hosting the Playon software. After a connection is made you can then stop the media device and then observe on the computer under “All Users” task manager that Playon has launched several instances of iexplore.exe When a player has stopped, normally it’s supposed to close all instances of iexplore but with Comodo, somehow those instances persist and as you watch more movies from the computer, more instances of iexplore will continue to propagate and before you know it, all your physical memory is eaten up.
With the firewall I’m using now, it doesn’t seem to do that. Not sure what is causing the issue between Comodo and the program. I know TVersity on the other hand doesn’t have these issues, but I must say that TVersity’s Hulu support is horrendous.

One thing I would like to add after posting my issue on the Playon forum and receiving a response from one of the devs is that the problem isn’t that the program needs to be whitelisted. The problem is that even when the program is whitelisted in Comodo, it continues its bizarre behavior. I have verified that the issue goes away after Comodo has been uninstalled and replaced by another firewall (not an ideal solution).
Not to name names, but has anyone else come to the conclusion that Agnitum’s software is utter ■■■■? I paid for the software years ago and have had nothing but problems from driver bluescreens to applications failing to launch while the firewall is running (as soon as the firewall service shuts down, the hung app mysteriously comes to life and appears and yes the app was whitelisted). Just thought I would get others opinions…

I’ll try and do some tests with this later today. I’ll let you know how I get on.

Cool! Please let me know what you find out as soon as you can! Just remember that in order to duplicate the problem you have to access the PLayon server with a PS3, XBOX or some other DNLA device.

Well for what it’s worth I was able to get Playon working in conjunction with XBMC Media Center for Mac OS X, Windows and Linux which is a fully DLNA compliant application. (I don’t have a playstation, xbox or TV)

After installing Playon and letting it create what ever rules it required, I then hooked up xbmc from another PC and used it UPnP search to find The Playon server. I then added content from You Tube and ESPN and was able to watch both in xbmc via Playon.

The attached show the rules created on both PC’s. The only thing I haven’t shown are the default rules created when one creates a Trusted Zone.

[attachment deleted by admin]

After watching the movie, did you check the tasks running uned “All Users” to see if there were many instances of iexplore running in the background? What happens with Playon + Comodo is that sure the videos will play however after watching several movies in a row, your memory will begin to be eaten up by several iexplore processes. Why it does this I have no idea. I never had any issues with being able to watch movies using Playon and Comodo.

I don’t actually any instances of IE at all, either during or after. Personally I don’t use IE, I also have it blocked in my firewall.

I did notice, however, that the MediaMall Server Service uses quite a lot of CPU time, but it does that regardless of CIS being installed.

[attachment deleted by admin]

Ahh okay cool! The reason I’m asking is that I understand that Playon uses the iexplore process whenever you access PLayon to watch a movie remotely. It’s interesting because when I posted on their forums about the issue I’m having, they immediately asked if I was running Comodo which I was. Maybe I have to go in like you did and manually whitelist the application.

Hi TronixA8372.

I didn’t actually white list the application, I just set my firewall to custom with alerts to very high and watched what happened. In the screen shots I posted you can see the results.

Thought I’d share what I managed to find out, hopefully it will help some of you (including the developers) with this problem. It took a lot of installing and uninstalling, but I managed to narrow the problem down to the Defense+ software. The problem happens when installing the antivirus software or the firewall & defense+ software. If you install ONLY the firewall software (choose “firewall only” when prompted during install), then the multiple window problem is gone and Hulu works fine on the console through Playon.

This was a relief for me because I really wanted to keep Comodo’s firewall (there are other anti-virus I don’t mind using). Hopefully this won’t be a problem at all in a future release, but for now this is a decent workaround.

Curious, I have D+ and AV installed as well as the firewall.

I have to wonder if it’s a problem with CIS and IE. AS I said I have IE locked down entirely and regardless of how many shows I watch, I never see the ‘windows’ to which you refer.

Interesting. Clearly I’m not nearly as knowledgeable on either side of the issue, but maybe there something different that happens when using PlayOn to view Hulu on a console. Specifically, I’m using the latest versions of both programs and viewing on the Wii (all other videos work fine too, it’s just Hulu that’s the problem). I tried whitelisting playon, as well as disabling defense+ from within the program. I also tried killing all Comodo processes and keeping them from starting up with windows (registry/services). The only thing that worked was uninstalling Comodo completely (and then reinstalling w/o defense+).

Ahh perhaps it is Hulu since that is the only web-based site that I use to access with PlayOn. It does seem to be the case that if you use PlayOn to watch Hulu then you’ll get the numerous instances of iexplore.exe which are quite the pain to close. I’m a bit reticent about disabling the Defense+ option with Comodo simply to relieve the symptoms but perhaps I have no other choice.

Anything new regarding this issue? I haven’t seen any response in awhile.


Unfortunately, I’ve gone as far as I can as Hulu is unavailable outside the US.