Ping Reply [Resolved]

just run the “Shields up” check on
Every port was perfectly stealthed; my computer seemed to be safe. The only test my computer failed was the ping test to which it happily replied (didn’t happen with 2.4).
Any ideas how to set CFP to not reply to ping request?
Thanks in advance for all your help.

Set up a new rule in network monitor:

see the attached screenshot, network rule 7 in my case.

When you create the rule make sure you move it above the rule that is number 8 on my list (number 6 on a new install I think). It is important that that ‘catch all’ rule is last on the list!


[attachment deleted by admin]

Actually, grampa (with the small G ;)) is using 3 beta not 2.4 as hinted in his parenthesized part. (Confirmation for that is here).

Hey Soya (or whatever impersonator / usurper ;D you may be),
I’ve always marvelled at your ability to find / remember threads from the (in this case not so long ago) past. Your memory is very impressive and so is your ability to spot little well hidden hints on current CFP versions.
N.T.T.W., I apologise for not stating anywhere in my post which version I’m using. My fault! I’m most grateful for your help (here and in all the other circumstances you have helped my in the last weeks (see Soya Lv.2, I can also remember things from the past (:TNG)).
Thank you everyone and please do not stop helping me out.
Any further ideas are most welcome.
Grampa (for the first and probably only time with a capital ‘G’ ;)).

That says you don’t use 2.4 anymore, as ‘did not’ is about the past.

Anyways, I don’t use CPF 3, so I don’t know anything about it.
But can you possible apply the rule that N.T.T.W posted?
My suggestion is to look in network rules and see if you can create a rule similiar to N.T.T.W’s.


I too am getting the ‘failed’ result because my system ‘REPLIED to our Ping (ICMP Echo) requests’
can anyone please help me to stop this happening in the latest beta version in vista?
I did add the additional rule regarding the ICPM echo but it still didn’t work.

any help would be very much appreciated.

many thanks.


Hey everybody and thanks for your ongoing support!!!
Unfortunately, N.T.T.W.'s ‘big picture’ ends after rule 5. Fortunately, I learned a lot from the folks here at the forum, so I think I understand the workings of network rules quite well - hopefully well enough to solve my problem.
Again UNFORTUNATELY, I don’t know an awful lot about the workings of pings etc.
However, if I find the time, I’ll have a closer look at my ruleset and am sure I’ll come up with a solution, which - this goes to Mike1959 - I’ll post in this thread for sure. Don’t know when I find the time though :P.
P.S. Maybe N.T.T.W. can post his rule #7 again ?

EDIT: N.T.T.W., tried again and the picture is now working. Thanks a bunch!

had several problems with CFP and CAVS beta versions so I decided to go back to my old setup. But…now even CFP v2.4 replies to echo requests. I have the same block rules as N.T.T.W. but my computer still happily replies to shields up’s echo requests. Consequently, checking CFP log files, I can find nothing about any pings blocked.
Any ideas?
As I said before, in the good old days I passed the test (true stealth) even without the default network rules.
I did, however, disable some windows services. Maybe that’s the key to… hm, thinking about it, a block rule for echo request should actually do the job even if all ‘evil’ services are enabled.
Thanks for your suggestions.

Here’s another great way to block ping with Windows built-in IPsec that you might take a look at:

You may try it, tho I understand you want to make CPF 2.4 block ping, and I have no idea why it doens’t block if you got a rule to block ping…


please set a ICMP echo request block in network security policies\Global rules.

[attachment deleted by admin]

Remove any routers and re-scan. Default 2.4 rules already block ping.

Hey grampa,

Are you CERTAIN it’s not your router responding to ShieldsUp? 'Cause it will. :wink:

Oh boy, me brains have rusted. Of course it’s my router.
Thanks everybody and please forgive my stupidity.
:-\ :-\ :-\ :-\ :-\ :-
Boy, I’m embarassed!
I truly deserve the name grampa (brainwise ;D).

Can anyone plz post a screenshot of the default rules? They work perfectly for me and I messed with them! Would be much appreciated!

You’re doing better than your son:

(:CLP) (:CLP) (:CLP)

He may be gluttonous but he’s smart :wink:

But look at what I can do:

[attachment deleted by admin]

I smell off-topic… :■■■■


Don’t be so ■■■■■■■ him. You’ll have to forgive the elderly for alzheimer.

Here. You want on-topic? Here ya go (assuming the question was for v2.x):;msg39465#msg39465

Hey Soya,
thanks a lot for… erm, for…, errrrrrm, for… bloody hell, I forgot and who’s that Soya person anyway? (:TNG)
Seriously, thanks a bunch for linking to the default set. I was exactly what I ‘recreated’, but I wasn’t sure at all.
Boy, I smell on-topic. Scary ;D
Ronald Reagan.

fixed !

many thanks to all for your support and suggestions…
I changed the network security policies\Global rules from in/out to just in and it worked…
puzzled why it didn’t work when set to in/out but what the heck it’s working fine now…thanks ‘gibran’

this is the only firewall that I’ve been able to achieve a ‘full stealth’ on my system…
many thanks for a great product.


strange because today my system is once again responding to the ping from the site…
I’ve checked the network security policies\Global rules and they are still the same
but it’s still responding to the ping…anyone have any other ideas on this or could
it perhaps be a beta glitch?

thanks in advance for any help.