Periodic boot error: COMODO Security Agent could not be loaded [M864]

Thank you. I have now updated the first post, re-opened this in the tracker, and moved this report back to Format Verified.

Thanks again.

In the main post under:
B. YOUR SETUP (Likely the same for each issue, so you can copy forward)

  1. Exact CIS version & configuration

CIS v7.0.313494.4115

Thanks.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic subject, NOT here.

  • Can U reproduce the problem & if so how reliably?:
    Random. It happens maybe every 30th boot.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
    1:Install CIS
    2:Every once in a while when starting the computer you will get a message from the CIS diagnostics saying it could not load the program.
    3:It is possible to manually start CIS by clicking on the shortcut.
  • If not obvious, what U expected to happen:
    CIS should always load correctly every boot.
  • If a software compatibility problem have U tried the conflict FAQ?:
    NA
  • Any software except CIS/OS involved? If so - name, & exact version:
    None
  • Any other information, eg your guess at the cause, how U tried to fix it etc:
    The gadgets and the icon next to the clock are not loaded. seems Cis.exe does not load correctly under CisTray.exe.
    A Full Dump of CISTray.exe during a time which CIS did not load correctly can be downloaded from here:
    MEGA
    A screenshot showing how Cis.exe should be loaded under CisTray.exe is attached to this topic. Note that during the times where CIS does not load correctly CIS.exe does not load under CisTray.exe.

B. YOUR SETUP
[li]Exact CIS version & configuration:
Version 7.0.317799.4142. Configuration Proactive Security.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
    All modules enabled.
  • Have U made any other changes to the default config? (egs here.):
    Antivirus: Scan computer memory after the computer starts is checked and the heuristics are set to high.
    Firewall: All options in the advanced part of the firewall settings have been enabled.
    D+/HIPS, Autosandbox/BBlocker: HIPS enabled with the default settings of proactive mode. Viruscope activated and enabled to isolate and automatically reverse. AutoSandbox the only change is the move to Untrusted.
  • Have U updated (without uninstall) from CIS 5 or CIS6?:
    No.
    [list type=lower-alpha][li]if so, have U tried a a clean reinstall - if not please do?:
    Yes, but the problem still remains.
    [/li]- Have U imported a config from a previous version of CIS:
    No.
    [li]if so, have U tried a standard config - if not please do:
    NA
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
    Account system administrator. UAC is set to default. Windows 7 Ultimate, SP1, 64bits.
  • Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
    a=None b=None
    [/list][/ol]

[attachment deleted by admin]

Thank you. I have updated the tracker and added the additional information you have provided as well.

okay,
Thanks.

Hello,

Same problem here.
When i uninstall the comodo firewall and restart Windows, there are some registry entries from CFW.
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\CmdAgent
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\services\CmdAgent
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet004\services\CmdAgent

These registry entries are not accessible and cannot be deleted.
It may be potentially problem. How can I delete these registry entries ?
I have to always run diagnostic tool and manually start the “cistray” ;-(
WT* is wrong the with “cmdagent” ?
I am already frustrated and I don’t know what can I do. ;-(

I use Windows 7 x64, CFW v. 7.0.31779.4142

[attachment deleted by admin]

Hi xwing,
See if the solutions posted in replies 9 and 10 of the topic in the link below help remove the registry entries.
Error Message: Cannot find initialization data file

Kind regards.

Hi captainsticks,

Yes, I tried it, but no success.

My steps:

  • unistall CFW and restart Windows
  • run “CIS cleaning tool” by community, CCleaner, sc delete “cmdagent” and restart Windows
  • there are still registry entries by cmdagent
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\services\CmdAgent
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\services\CmdAgent
    HKEY_LOCAL_MACHINE\SYSTEM\ControlSet004\services\CmdAgent
  • install CFW and restart Windows
  • still get message “Comodo agent could not be started” :frowning:

update:
Still COMODO Security Agent could not be loaded and here is the windows eventlog message:
A timeout was reached (30000 milliseconds) while waiting for the COMODO Internet Security Helper Service service to connect.
The COMODO Internet Security Helper Service service failed to start due to the following error:
The service did not respond to the start or control request in a timely fashion.

I tried everythings like RunSysytemAs, PCHunter64, “sc delete cmdagent” but NOT SUCCESS.
Still cannot delete registry entries:
HKEY_LOCAL_MACHINE\SYSTEM\ControlSet00()\services\CmdAgent
(
) numbers 1,2,3,4

I’m afraid that windows reinstall imminent.
Two months it works very well a two day ago suddenly this sh*t happened.
I don’t uderstand, I am going to die (:AGY)

update2:

I spent the whole weekend solution to the problem, but sill no success.
There is definitely corrupted permissions in registry entries by Comodo uninstaller, I think…
When I install Comodo Firewall again, after restart Windows still get know message :Comodo agent can not be started", because permissions in registry entries is corrupted, I think.
Can someone help me, how can I delete the registry entries before install Comodo Firewall ?
The video as evidence.

Regards
xwing

[attachment deleted by admin]

It maybe that if you change the timeout on Service loading, you will resolve this.

This MS KB deals with it I think: A service does not start, and events 7000 and 7011 are logged in Windows Server - Windows Server | Microsoft Learn

Do make a restore point before you do this for safety.

Mouse

I’m sorry, I don’t use any restore point. I know, my mistake.
But the timeout is not problem, check the small video.
This can fix the diagnostics tool (cis.exe ? ) only.
BTW…Which option is used for start diagnostics tool ? I will put it to windows startup :wink:

xwing

[attachment deleted by admin]

If diagnostics find no errors it is not doing anything. Does it find any errors?

I suggest making a restore point before the change I suggest

I would try the change if I were you :slight_smile:

Mouse

Ok, I understand that better is making a restore point.
BUT in this case is too late. What now ? Do you suggest reinstall Windows ?
WHY the diagnostics tool can start Comodo agent, BUT user (admin) cannot do this ?
What exactly does the diagnostics tool ?

xwing

Please execute the following steps:

  1. Make a restore point now
  2. Click Start, click Run, type regedit, and then click OK.
  3. Locate and then click the following registry subkey: HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  4. In the right pane, locate the ServicesPipeTimeout entry. Note If the ServicesPipeTimeout entry does not exist, you must create it. To do this, follow these steps:
  5. On the Edit menu, point to New, and then click DWORD Value.
  6. Type ServicesPipeTimeout, and then press ENTER.
  7. Right-click ServicesPipeTimeout, and then click Modify.
  8. Click Decimal, type 60000, and then click OK.

Best wishes

Mouse

Ok.
My steps and results:

  1. I made restore points
  2. Created DWORD ServicesPipeTimeout with decimal number 60000 in the HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control
  3. restart the Windows 7
  4. after restart still appears error message “Comodo agent cannot be started”
  5. click “yes” and run Diagnostics tools
    6 go to point 3 and over and over :wink:

I appreciate your help.
Thank you

xwing

Ok thanks for trying it. It works on quite a lot of systems.

Sorry it did not on yours

Mike

The devs have not marked this as Fixed in the tracker. However, sometimes bugs are fixed by the release of new versions, but not marked as Fixed in the tracker.

If you are able please check with the newest version (CIS version 8.0.0.4337) and let me know if this is fixed on your computer with that version.

Thank you.

Already installed the version 8. I need a few days to respond. Makes a day that I installed the new version and so far the error has not appeared!