PC freeze pressing Print Screen key

I want to fix pressing Print Screen key ask dialogs.

Pressing Print Screen key if checked ‘Ask’ Computer Monitor,PC go to freeze…

  1. What you did:
    Sample Application setted to Computer Monitor ‘Ask’.
    And press Print Screen key on active this Application.

  2. What actually happened or you actually saw:
    First,OS is freeze.all action was No answer.
    After 2 or 3 clicks,PC gone freeze…

  3. What you expected to happen or see:
    Want to CIS Dialogs appear at pressing Print Screen key.

  4. How you tried to fix it & what happened:
    Change to ‘Computer Monitor’ to ‘Allow’.
    but this is not to want.

  5. If a software compatibility problem have you tried the compatibility fixes (link in format)?:

  6. Details & exact version of any software (execpt CIS) involved (with download link unless malware):
    CIS:ver 5.10.228257.2253 VirusDB:12885
    Sample Application:Firefox(vendor list deleted)

  7. Whether you can make the problem happen again, and if so precise steps to make it happen:
    0:Check OFF related to ‘use Cloud DB’ all settings into AV, FW and D+.
    Check OFF ‘Create rules sage applications’ into D+ Settings > Genaral Settings
    1:Prepared sample application.
    (plz Those not listed in the vendor list.
    If want to check Major App, delete this files onto ‘Trust Files’,related ‘Vendor lists’
    and cache into CIS Programs folder. reboot CIS GUI.)
    2:Add D+ rules this App.Edit Customize ‘Computer Monitor’ to ‘Ask’
    3:Active this App & Press Prtin Screen key.

  8. Any other information (eg your guess regarding the cause, with reasons):
    I using CIS without cloud DB and vendor list.
    B. FILES APPENDED. (Please zip unless screenshots).:

  9. Screenshots of the Defense plus Active Processes List (Required for all issues):

  10. Screenshots illustrating the bug:
    PC freezed,can not get screen shots

  11. Screenshots of related CIS event logs:
    No event logs.

  12. A CIS config report or file:

  13. Crash or freeze dump file:
    can not get dump

  14. Screenshot of More~About page. Can be used instead of typed product and AV database version:


  1. CIS version, AV database version & configuration:
    CIS Premium 5.10.228257.2253 Virus Sig DB 12885
    Useing Proactive Security.
  2. a) Have you updated (without uninstall) from a previous version of CIS:
    back up config files and Clean Uninstalling previous versions.
    b) if so, have you tried a clean reinstall (without losing settings - if not please do)?:
  3. a) Have you imported a config from a previous version of CIS:
    b) if so, have U tried a standard config (without losing settings - if not please do)?:
  4. Have you made any other major changes to the default config? (eg ticked ‘block all unknown requests’, other egs here.):
    Changes all related ‘using cloud’ to OFF.
    Changes ‘Create rules for safe applications’ to OFF
    Vendor list, Trust file list, these cache files deleted,and adding this list only.
    Microsoft Windows Compnent Publisher
    Comodo Security Solutions,Inc
    ATI Technologies ULC
    Microsoft Corporation
  5. Defense+, Sandbox, Firewall & AV security levels:
    D+:safe mode, Sandbox:disabled, Firewall:safe mode, AV:On Access
  6. OS version, service pack, number of bits, UAC setting, & account type:
    Windows XP SP3 32bit,Admin account using
  7. Other security and utility software currently installed:
    No use another security.
  8. Other security software previously installed at any time since Windows was last installed:
  9. Virtual machine used (Please do NOT use Virtual box)[color=blue]:
    Vmware 4.0.0. but this bugs no using this.
    but this bugs no using this.

Great idea to use the bug format to ask for help BTW

Something very strange here. Winlogon is running as unknown, that’s not good.

I think its probably because you are running with a tailored vendor list, and this may not include all Microsoft certification authorities. If that’s what you want, fine, CIS can be used this way, but you will have to work hard to ensure all the necessary MS files are marked as trusted files, and a few may even need to be restarted after boot. One of the other mods runs CIS this way and may be able to help you with this specific problem.

If you are not running with a tailored vendor list there is a possibility that you are infected. In which case you should probably immediately (without rebooting) follow Chiron’s advice on the ‘how to find out if you are infected’ FAQ here, and report back the results.

Best wishes



I missed check that process…
Now add this on vendor list.thx mouse1!

OK is problem now solved?

Best wishes


I have exactly the same problem.

My computer freezes when I press PrtScn key if the application which I’m trying to make a screenshot of has “Computer Monitor” access policy set to “Ask” in Computer Security Policy of Defense Plus. This freezes OS and all the software; the mouse cursor still can be moved, but the computer won’t response to mouse clicks or keyboard keys. After 2-3 attempts of mouse clicks, the mouse cursor also freezes. If I leave the computer alone for 15-20 minutes, it comes back to life. But pressing PrtScn again brings the freeze back, and so on.

Logically, I’d expect Comodo to pop up an alert window with a warning about the application’s attempt to access the screen directly instead of freezing the computer.

If I change the “Computer Monitor” access policy for the given application to “Allow”, the PrintScreen button works fine, no freezing.

Unfortunately, I need to do lots of screenshots of the Internet browser contents, but I’m not sure that allowing the monitor access to a browser is a very secure approach.

Unlike the original poster, I don’t have winlogon running as unknown, it’s in Windows System Applications.

Any ideas how to fix it other than allowing monitor access to each application I need to take a screeeshot of?

CIS version 5.10.228257.2253
Win XP x64