Password is invalid trying restore from zip file

I have been running Comodo to backup a directory tree containing many shared folders on a small file server. It has been running for over a year as a Windows scheduled task. Unfortunately in all that time Comodo backup has not been updated, and nobody has bothered to test if a restore can be done.

When I attempt to do a restore from a backup file, using Comodo>Restore>My Computer, and then select the file. It prompts for the password but I then get an error: Password is invalid or this is not a valid cbu backup file. This sort of makes sense since I opted to use zip files in the hopes that a restore could be done without needing CBU.

The backup runs from a batch file with the following command:
“C:\Program Files\COMODO\COMODO BackUp\CBU.exe” /script “G:\” is as follows:

/backup_operation /type filesandfolders /source “D:\USERS” /simplecopytozip /exclusionfilter “.tmp|.bak|*.7z” /compressionlevel low /encryptionpassword “redact12” /encryptionalgorithm “aes” /description “Daily Users Backup” /destinationtype destinationtypediskfile /destinationpath “G:\Backup\Daily|DATE2|” /backup_type full /diskusage normal /processorusage normal /log_file “G:\DailyUsers.log” /log_method “append” /silentRun

As I said, the backup has been running to completion without error all along. I can open the zip file with 7-zip, however I also get an error when attempting to extract any file (Unsupported Compression Method…)

Additional details: The backup destination drive (G:) is a USB external hard drive. I have tried copying the zip file to a local disk to do the restore. This made no difference.

This system was set up over a year ago. I can remember testing to make sure everything worked at the time, but can’t remember if there is something I am forgetting to get this to work now?

EDIT: Looking back at my posting history, I asked a similar question when I was testing this. It seems at the time, I discovered that zip files larger than 5GB exhibit this problem. The backup has grown to be larger than this since it was put in place, and that appears to be the problem.

I got no replies to my query about this back then. Does anyone know a fix or workaround for this now?