P2P programs triggered 0 notification on launch

Because I checked the box to receive few notifications when I set up my firewall.

I have been using Comodo firewall for more than 5 years, and I always did everything manually. Recently when I installed it on the current computer I use, I set the intaller to notify me as little as possible. I thought this means Comodo firewall would sort the programs and automatically apply rule sets for them, and would only ask me for input when a unknown/risky program doesn’t fit any of the existing rule sets, but this doesn’t seem to be the case

Today when I opened a p2p torrent application for the 1st time, there was 0 notification, and the program worked without asking me for any input. I had no idea which ruleset that the p2p application was running, this means other programs I might have run in the past was also doing the same thing because of my settings.

What exactly happens when a user chose to receive few notifications during install? Why does potential security risks like a p2p program not trigger a notification under this setting?

Because the p2p program or its vendor’s digital signature are on the safe list and your probably running at the default of safe mode, which means only popups for unknown programs.

I think its time your familiarize yourself with the program: Comodo Internet Security, Antivirus protection, Firewall Software |Security Help

I know of no firewalls that automatically apply proper rules. Normally their allowing all types of communication (i.e. all ports & protocols). Similar to the allowed application rule in Comodo. Which is the default rule applied for trusted applications. At best the program will restrict itself to specific protocols usually TCP or UDP, but that really only happens for a firewall the developers know is going to be there (Windows Firewall) an have an API to communicate with it.

But can you make it so that the program only automatically apply certain types of rules? Right now the automatic rule creation always the program to run everything, but I want to default them with my set of rules instead.