p2p problems after update

For some reason I can only get local connections from bitcomet right now after the update reset my p2p rules and made me redo it all over again.

I thought I changed back the the same rules and should be fine, but I was wrong. I cannot get a single Remote connection from bitcomet at all even though the torrent is still new and very healthy.

these are my rule set for bitcomet
allow incoming UDP TCP, destination port # is my bitcomet port
allow outgoing TCP, any port
allow outgoing UDP, any port
allow TCP out at dest. port 80
IP block all other connections.

global rules
block ICMP in echo request.


Do you have a global rule that allows incoming traffic on the listening port? If yes, make sure it’s located over all block-rules. If no, try to create one (it should be similiar to the application rule that allows incoming traffic).
Have you choosed Alert me of incoming connections - stealth my ports on a per-case basis in FirewallCommon TasksStealth Ports Wizard?
Is there anything about BitComet in the firewall logs?

The thing is the torrents can still run, but no remote connections.

And I used the same set of rules before and it worked fine. There were only ICMP block incoming echo request in global rules and nothing else, and it worked fine before version 309, I don’t see why I need the rule now

I did set Alert me of incoming connections, and there are no firewall entries about bitcomet since then.