Outbound mail filtering from dynamic IPs

I have had my Exchange server using Comodo’s smtp servers as a smart host for quite a while and per previous instructions set a username that matches my current IP address, otherwise all outbound email submitted to a Comodo for delivery gets bounced back as ‘550 message submission is for authorised users only!’

Even though I have a dynamic IP, it usually only changed once or twice a year. Lately it has been changing multiple times each week making it challenging as I have to log in to the Comodo portal and update the username to match my wan IP address. I just can’t do this anymore.

A while back, a support person told me that I could create an account and configure my smarthost settings to authenticate with it… I have been configured that way all this time, but Comodo still bounces my outbound mail if I don’t also have a username that matches my wan IP. How do I fix this?