Option "processActivity" in KillSwitsh not work Outside sandbox

Hi all

1. The full product and its version:
COMODO Internet Security 8.0.332922.4281 BETA
2. Your Operating System (32 or 64 bit) and ServicePack revision. and if using a virtual machine, which one:
virtual machine : virtualbox 4.3.6 r91406
windows 7 sp1 X32

3. List all the configuration changes you did. Are you using Default configuration? If no, whats the difference?:
Default configuration
4. Did you install over a previous version without uninstalling first, or import a previous configuration file?:
Clean install
5. Other Security, Sandboxing or Utility Software Installed:

6. Step by step description to reproduce the issue. Or if you cannot reproduce it, what you actually did before it happened, step by step:

1:When I run any sample without sandbox, the option “processActivity” not monitor ​​any events
2:in CIS7 processActivity work normally inside sandbox or without ,but in CIS 8 beta processActivity it can not monitor any events outside sandbox , but it work normally inside sandbox
3:Just it not work outside the Sandbox, either within the Sandbox are working normally

7. What actually happened when you carried out these steps:
Does not show any events of the sample, such as a network connection or create a process

8. What you expected to see or happen when you carried out these steps, and why (if not obvious):
I see all the events of any process, whether inside or outside the Sandbox

[attachment deleted by admin]

test CIS 8 Beta

this video show the processActivity not work without sandbox

[attachment deleted by admin]

Could you try going into the advanced settings and then viruscope settings and then disabling “Monitor sandboxed applications only” setting if it’s disabled, and then try again?

I think (not sure) that the Process Activity is built on Viruscope and if that setting is enabled then viruscope won’t monitor applications outside of the sandbox meaning no process activity data to show. But like I said, I’m not sure if this is the case.

I was going to suggest the same thing. sd ahmad, please check what happens if you disable that option and let us know. However, if the results are the same no new video is needed.


Thank you, the issue has been resolved :-TU

I’m very happy to hear that. In that case I will move this bug report to Resolved.