On Access Scanner Error


After finding that CPF has a conflict with Avast/Outlook2003 I uninstalled Avast (reboot) and installed CAVS (reboot) and the very slow boot time (30-40mins) went away.

But now I attempted to enable the On Access Scanner (was disabled after reboot) and I get the following error:

Comodo AntiVirus encountered and error
Number: STEB017
Desc: Unable to perform requested operation


Did CAVS download any updates which later required a reboot? There was an update today that would have asked for a reboot and not rebooting may cause this.


completed the update and rebooted the PC and still same error. In the process of doing a full scan to see if this helps

Have you checked to see wether or not the avast services are still running? You may have to disable them manually if they didn’t uninstall with the installer.

Sorry, I’ve not come across this problem before.


If you open CAVS what do you see. Are the scanners on?


all Avast services gone, scan still in process going quite a bit slower then others.

The following should remove all traces of avast! Then we can see if this is what is causing the problem:


ok ran the Avast cleaner and there were some files still there. Completed the full sys scan then rebooted. Boot was a bit slower then normal but I still can’t turn on the OAS. The error has changed though its now:


The rest of the error remains the same.

weird, i get the same error if i try to turn off the email scanner or the automatic updater

That’s interesting. I think you should contact support about this. They can hopefully help you better with this.


If they resolve your problem, can you please back the resolution.


thanks for the help submitted two tickets

Ok, I’ve actually just thought of something. Do you have SpywareGuard installed? If you do, you might want to read through this post as this is what is most likely causing your problem.