On-Access Scanner causing a sharing violation

I have been having issues with Microsoft Excel 2007 and the On-Access Scanner. When I try to save a changed document I get an error saying that a sharing violation has taken place and it won’t let me overwrite the document. It doesn’t seem to give an error with word documents or any other program for that matter. When I turn off the on-access scanner i don’t get the error messages. Is this a bug or how can I correct this?

Here is the error:


Of course on the hour long call with microsoft tech support we finally got smart and disabled the scanner.

I don’t get any errors with excel or any other programs - perhaps it is due to some excel add-in that is installed?
Might be worth checking tools/add-ins to see what may be a possible culprit. If there are a few present you could try disabling them one by one to see if any cause the problem.

The only other thing I can think of is to exclude excel from on-access scan but this would be a last resort and I would only do this if you cant get it to work any other way and you totally trust that your excel files are from a safe source.


I only did the default install with office home & student 2007. I have tried disabling addins to no avail. I also excluded xls from the list of file types in the on access scanner settings. The files are the new .xlsx format and it didn’t solve the problem to remove xls from the list. Makes me think that the scanner isn’t the problem after all but still when I turn it off it works fine. What can be wrong?

Sounds like you have some corrupt office files, try using office 2007 diagnostics:

The Microsoft Office Diagnostics program contains six tests that check various parts of Office 2007 and your computer. The program checks such things as your computer’s memory and hard drive, corrupt files, and registry settings. The following links may help:



I ran the diagnostics before calling MS and there weren’t any problems. I never had problems before this with the on access scanner causing issues. I don’t know where to go from here. Thanks for trying.

You say you excluded xls from the list of file types in the on access scanner settings but this did not work as the files are now xlsx: have you tried excluding Excel completely from on-access scanning? In advanced settings you can select files or even entire folders that will be excluded from on-access scanning. Screenshot attached.

If this still won’t work, have you checked if the file you are saving to has had its permissions changed, i.e. has the write access been removed so the file cannot be written to. I am told this happens a lot with Excel 2007 and changing the permissions back works, at least temporarily.


[attachment deleted by admin]

I don’t think the permissions are being changed, at least not viewable with explorer, when the files are opened and aren’t able to save. What happens is when opening an existing file (whether in the new .xlsx or the old .xls format is used) changes being made are not able to be saved to the same file name. I can disable on-access scanner from scanning “all files” and make it selective but even when the file extension is not in the list (xlsx) it still scans it when opened by excel and I am not able to save. It is not very practical for me to create a bunch of rules to exclude scanning for each excel file I have. I really think there is something wrong with the way the on access scanner deals with office 2007 excel. It doesn’t seem to happen with word or powerpoint. Does anyone else use office 2007 and have or not have these problems? Is anyone at Comodo able to help me out with verifying this? I can turn off the scanner and make changes to and save any xls or xlsx file I want. But when the scanner is on I can’t.

Have you tried excluding the excel folder from on-access scanning, by this I mean the actual executable for excel rather that any individual files.
Select Settings/On-Access scan/Advanced/Select Items to exclude from On-Access Scan. Click on ‘New’ and browse to the location of the excel.exe file in the office folder of program files. Select the file and click OK. Click OK again and then click on ‘Apply’.

If it is the on-access scanner affecting excel then this should fix the problem.


Excel should appear on the exclude list as per ad-aware shown in the attached screenshot example:


[attachment deleted by admin]

I tried excluding the excel installation folder in program files but that doesn’t work. I also tried selecting just an individual excel file and it still doesn’t work. The only thing that works when trying to exclude is excluding the parent folder of the excel file that you want to work with. I don’t like that I can’t just exclude individual files ( I can it just doesn’t function properly) without moving them into a special ‘no access scanner’ folder. No one else having issues with the scanner?

I assume you are not using Vista as CAVS is not ready for Vista: Have you tried excluding excel files located in documents and settings? Not sure if this will work with excel 2007 but might be worth a try. The only other suggestion I can think of is for you to submit a support ticket to Comodo as this sounds like a compatibility issue - perhaps it will be fixed with the next beta or maybe the team can fix it sooner?


Nope, I’m using Win XP Pro, Office 2007 Home & Student. I do believe there is a compatibility issue. I have also noticed with this release of CAVS that certian installers including the MS Office 2007 fail if the on-access scanner is active. In order to get the installers to finish without errors I have to disable the scanner temporarily, which is not an issue: just different than the previous versions of CAVS. For now I have disabled the scanner for the parent folder of the files that I want to work with.

Lets hope the next version of CAVS fixes these issues and a few others :slight_smile:

Hi guys,

I’m having this same problem.

System specs:
windows XP home sp2
ms office home and student 2007 - default install

the files are not set to read-only.

With the on-access scanner enabled, I get the “sharing violation” error message whenever I try to save an excel file.

With the scanner disabled (not the whole antivirus program, just the on-access scanner part of it), everything works fine.

I’ve tried the suggestions in this thread, but they didn’t work. Has anyone else found anything?


I have the same problem.

System Spec:
Windows XP Pro SP2 (Swedish)
MS Office Enterprise 2007 (Swedish)

I hope they fix this problem in the final realease.


I have the similiar problems too.

  1. When i try to install some Application problem occure (“can not create file …”) but when I disabling On access Scanner installation sucsseded.
  2. Sharing Violation error shown when using MS Visual Studio (Saving edited file)

Hope in the next release the problem can be resolved.



I started having this problem when saving an Excel file (using Excel 2007) onto a Thumb Drive. I was able to re-create the problem by saving it to my hard drive. I tried saving as a .xlsx and a xls file with the same results.

This problem does not occur if working with Word 2007 files…so it is particular to Excel 2007.

The only thing I could get out of Microsoft’s Knowledge Base was that there was a share violation. I made sure that I shared the Thumb Drive and made it available to the rest of the network…but that did not make a difference. Obviously, my hard drive is already available to the network and I still got the error message.

When I disable On-Access Scan in Comodo…the problem goes away. That seems to be the temporary solution…but it is NOT ideal…a solution from Comodo would be preferred.

BTW, I’m using XP SP2.



Yes, I am having the same problem and several other people in general seem to have this with their AV software. I think it has something to do with how Excel saves and tracks itself. I just found out that Excel actually puts everything in a temporary file and then exchanges that for the real thing when you save. I always wondered why changes to Excel weren’t spontaneous like they are for other Office programs.

What seems to be happening and the reason a previous poster’s attempt to get .xls (and all the other flavors to work) to be excluded from the On-Access Scanner is because it isn’t the .xls(*) file that is the problem. I am suspecting that the share violation occurs with this temp file which has no extension when tries to save it.

It appears that it will take someone at CAV to specifically check into this and come up with a solution in a future release. In the meantime, can anyone come up with a good workaround? So far, I’ve been able to save the temp file adding the .xls extension, go and delete the original file and then rename my temp file to the name I had.

I have an XP SP2 Home box with Excel 2007 Professional.

Best Regards,

I have the same problems is their a fix for this?

I’m having the same problem described by others above. WinXP Pro SP2, Excel 2007 and sharing violation error messages that disappear as soon as I exit CAV.

I can exclude Excel from CAV scans for a month or so. Hate to sound ungrateful about a good product that’s free to users, but the ongoing risk of an infected Excel file will force me to abandon CAV after that.

Thanks for looking into this.