"older version already installed" but cannot find it!

First off, unfortunately, I have a Vista 32 (Home Premium) computer. I found similar problems here with XP posts, but nothing with all my issues. I updated CIS, then it would not work. I ran diagnostic and it found errors, but said it could not fix them. I uninstalled CIS through add/remove programs because my computer could not find the cfpconfig.exe file and I could not get cfpconfig -u to work from the DOS command window. Then I downloaded CIS again from Comodo website and tried to install. Now I get a message that an older version is already installed that must be removed and asks me if I want to delete it. I click to delete it, but nothing happens. I followed a suggestion from theeldergeek and used jvtools 16 to remove the program. It appeared to remove it. Nothing showed up in the program list on the add/remove list concerning Comodo except i-vault and safe surf. I searched for CIS in the search box and found a couple of files (setup files) which I right clicked and deleted. I downloaded again and tried to install, but get the same message: An oder version is already installed and must be removed first. I have been through this cycle 4 times. I’m about to give up on Comodo. PLEASE, PLEASE HELP!

Hello And Welcome

Try To Remove It By Using Revo Uninstaller (www.revouninstaller.com)
And then restart, then Install a fresh…


Download and install Regcleaner and remove the Comodo related key(s). Now the installer should not see the older version anymore.