Offline installer - CIS wasn't properly signed. Error: 2148098050

Can you reproduce the problem & if so how reliably?:
I could only test it on one machine. Re-downloading didn’t helped.
If you can, exact steps to reproduce. If not, exactly what you did & what happened:

  1. Download offline CIS installer
  2. Run installation, wait few sec/%

One or two sentences explaining what actually happened:
After that, msg appears: 1) Internet Security wasn’t properly signed. Installation aborted
2) Error: 2148098050
One or two sentences explaining what you expected to happen:
CIS being installed
If a software compatibility problem have you tried the advice to make programs work with CIS?:
?
Any software except CIS/OS involved? If so - name, & exact version:
No
Any other information, eg your guess at the cause, how you tried to fix it etc:
Maybe online installer would work but this machine can not connect to the internet.

B. YOUR SETUP
Exact CIS version & configuration:
Cis_premium_only_installer_12.1.0.6914
Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
no
if so, have you tried a a a clean reinstall - if not please do?:
?
Have you imported a config from a previous version of CIS:
no
if so, have you tried a standard config - if not please do:
?
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Windows 7 64-bit SP1 Admin account some UAC level.
Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
a=0 b=0

You need to have kb4474419 installed which adds support for sha2 code signing.

Hi davis89,

Thank you for Reporting.
Currently we are not officially supported the offline Installer. Hence kindly check with Online Installer.

Regards,
PD

Why not?

And hence, I can not use the online installer, hence this topic.

Help me

Hello . . . . You may need to be a little more explicit with the help request!