now its blocking counter strike ?

yet more problems , :frowning:

iv just noticed that with the FW on even though iv set Steam.exe & hl2.exe to allow all IP and allow all TCP/UDP it still blocks my receiving the server list ? i can play fine i can even get the list of history servers but i cant get the main server list at all.

its now the second program im having to turn the FW off to use? (other one is Adobe Dreamweaver)

also noticed that svchost.exe is going mad when im trying to use either of these 2 programs is it supposed to be like this? pic. im getting like 50 inbound svchost.exe connections from the router at times, is this anything to do with my problems?

thx all.

[attachment deleted by admin]

Do you need an open port for incoming traffic for this? If so follow this tutorial (please edit for the appropriate port number (s) and protocol(s)):
To open the port TCP 1723

Firewall → Advanced → Network Security policy → Global Rules → Add → fill in the following:
Action: Allow
Protocol: TCP
Direction: In
Description: Incoming Port VPM

Source address: Any
Destination Address: Choose MAC or Single IP address (only when it is fixed) or Host Name
Source Port: Any
Destination Port: 1723

Then push Apply → Ok.

well i tried that, but i couldn’t get it to work, iv even put allow all IP & allow all tcp/udp rules in the global rules i put these rules right at the top and as i understand it should let everything through but still dont work.

so iv got global rules allow all IP & TCP/UDP
& the .exe’s for counter strike with rules allow all IP & TCP/UDP

and dont work. it dont even say what exactly its blocking in the FW events just a load of Windows operating system Blocked.

i just dont understand FW’s, iv tried almost all of the major ones on many dif comps and always have problems of one sort or another :frowning: and usually end up removing them, but i keep trying cos i really want a FW and the understanding of how to use it but they always seem to block things and i can’t figure out why.

anyhow pics of the advised “ports to open” (dont say if thats incoming or outgoing)
& my FW events whilst trying to get server list.

[attachment deleted by admin]

[attachment deleted by admin]

iv done a diagnostic run on comodo and its says iv got outpost installed but i haven’t had that on here for ages, must be some reg entry’s left somewhere.

should i search the reg for outpost and delete? then uninstall & re-install comodo?

could it be whats causing all my odd occurrences?

To make sure there are no traces of outpost left do the following. Download and run Autoruns. This tool will show all that starts up on your computer. So tread with care.

When running Autoruns let it hide the Microsoft and Windows entries under Options. This is to make sure you can’t disable Windows entries (this tool can seriously mess up your system). Now browse through the entries and untick all Outpost related entries. ALso keep an eye out for other firewall entries of firewalls you have used in the past.

After disabling startups reboot and try again.

yea, i use autoruns a lot so im quite comfortable with it, had a look but nothing in the startups , however i did remove manually all reg entry’s for outpost , uninstalled and re-installed comodo now its quite happy when i do the diagnosis.

so iv got a brand new installation of comodo and the only thing iv done is set up some allow all rules for the .exe’s of counter strike and in global as well (just for testing purposes) and then to try to get the server list up, but no still not having it.

pics of my settings and FW logs after ONLY running Counter strike.

[attachment deleted by admin]

Your Global Rules disables the firewall with the “allow all in/out UDP/TCP traffic on all ports”. What happens with the retrieval of the main server list when you disable the firewall? Are you sure the server serving the main server list is on line?

Are you using Defense +?

Are you using a router?

yea i am using a router , but that’s not the point (pls correct me if im wrong :slight_smile: ) but if i turn off the comodo FW it works but if turn back on the comodo FW it dont so the server lists are getting through my router fine !

i have set up my router all as instructed to do by Valve and it all works fine when the comodo FW is off.

im pulling my hear out now ( not so much left nowadays :smiley: )

any more suggestion from any1, or if some wants id be quite happy for some to have a remote assistance session with me to show me what iv got wrong.

thx all.

Please report to what I asked in the above.

What happens with the retrieval of the main server list when you disable the firewall?
if i turn off the comodo FW it works but if turn back on the comodo FW it dont
so that if i "Disable" the FW from the tray/FW behavior settings the i can get the server list fine, which also means the host for the server list is on and active.
Are you using Defense +?
yep, but it has to be something with the FW does it not if it works when the FW is off "Disabled" and Defence+ is ON

what i dont understand is what is the difference between having global rules to allow all/everything and “disabling” the FW as they should be equivalent ?

Your Global Rules disables the firewall with the "allow all in/out UDP/TCP traffic on all ports".
with these above rules it dont work but with the FW Disabled it does ??

if only i could find a FW that im comfortable with & iv got a reasonable handle on id be pretty quick to purchases it.

I think there is something not quite right with your CIS installation because disabling the Firewall helps and “disabling” the firewall in Global Rules is not working.

Unless somebody has a bright light bulb of an idea I would like to suggest to try a clean install without importing any previous configuration. To be sure it is a really clean install follow this guide (but don’t remove the Legacy keys as they are too much work):

Uninstall CIS and reboot. Then run [url=]Comodo System Cleaner[/url] to get rid off registry keys.

Then delete the Comodo folders under Program Files, Program Files\Common Files, C:\Documents and Settings\All Users\Application Data\ .
For Vista/Win7
Users%username%\appdata\local, Users%username%\appdata\roaming\ and \Users%username%\appdata\local\virtual store

To be even more thorough open Device Manager and set it to show hidden devices under menu option View. Then see if there are Comodo driver(s) left in non Plug and Play drivers. If so select the driver → click right → uninstall and reboot.

Now delete the following:
C:\boot.ini.comodofirewall (this file may not exist).
WARNING: Do not mistakenly remove the original “boot.ini”.

a. HKEY_CURRENT_USER\Software\ComodoGroup\CFP and HKEY_CURRENT_USER\Software\ComodoGroup\Comodo Internet Security
*(If you have other Comodo products installed, delete only the values
for CFP)
c. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
d. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services
e. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\cmdHlp
f. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\Inspect
g. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
h. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services
i. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\cmdHlp
j. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet002\Services\Inspect
k. KEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
l. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services
m. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\cmdHlp
n. HKEY_LOCAL_MACHINE\SYSTEM\ControlSet003\Services\Inspect
o. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdAgent
p. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdGuard
q. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\cmdHlp
r. HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services
s. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro
t. HKEY_USERS\S-1-5-21-1202660629-746137067-2145843811-1003\Software\ComodoGroup\CFP
kk. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x32
ll. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFP_Setup_3.0.14.276_XP_Vista_x64
mm. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CFPLog
nn. HKEY_CURRENT_USER\Software\Local AppWizard-Generated Applications\CPFFileSubmission
oo. HKEY_LOCAL_MACHINE\SYSTEM\Software\Comodo\Firewall Pro

*Note: It may not be possible to remove these “LEGACY” keys. If you cannot delete them, leave them in the registry. However, I have subsequently found that you MAY be able to remove these keys in Safe Mode by using a third-party registry tool. To permanently remove them may also require modifying the Permissions for each key. See:;msg119226#msg119226

Now you should be good to go

If you look at the log files, the blocks are being picked up by Windows Operating System, this is a generic host process and will catch requests for service that are not being handled correctly by other rules. This would suggest Steam/CS needs something else.

I would suggest the following:

Delete any application rules you have for steam/CS and make sure there are no block rules.
Open CIS/Firewall/Advanced/Firewall behaviour Settings
Put the Firewall in to training mode
Put Alert settings on low.

Now launch your game and see what prompts you get. This should set the Application rules. Once done you really need to think about tightening your Global rules.

well that was quite a job, to make sure it was all done correctly but iv done it all including DL’ing another copy of the comodo installation file (just in case).

however im afraid it still does the same thing ???

iv put the firewall Alert settings to high so i can see all activity’s and when i hit the button for the server list even though iv got the global rules to allow ALL TCP/UDP traffic it shows these windows operating system Blocks ? (pic below) it just dont make any sense. what are these block activity’s? why is it blocking them ? what are they ? what have they got to do with counter strike (not any of the ports needed for CS) ? but it is defiantly blocking them when the server list is trying to load i just dont see how to tell it not to block them, what they are or why they are getting blocked in the first place.

Crazy stuff…

p.s. thx for the comodo Cleaner utill, another nice little cleaner app to add to my collection, CCleaner, Advanced SystemCare, Glary Utility’s, to mention a few. so thx for that.

EDIT:- please note the above post was posted while i was writing this post.

[attachment deleted by admin]

thx for the help, however iv already tried that, after my last FULL clean and re-install i did not change anything apart from turning on Training mode, so i had a completely blank log of blocked actions, a new installation & default settings. when i try to get the server list it does a bit of learning (the popups) but still dont load the server list and still shows these Windows Operating System blocks (if iv got the alert settings at high, if iv got the alert settings at low it remains empty (shows no blocks))

[attachment deleted by admin]

The firewall log show port 52574 USP as incoming port. Please add a rule for incoming taffic on this port under Global Rules.

didn’t work, but iv already tried to allow ALL in the global so not sure how defining the single UDP port would make any difference but i tried it any how , pics at bottom

im fighting a losing battle here, looks like im going to have to just disable the FW when playing CS or using DreamWeaver, not good but its all i can do.

[attachment deleted by admin]

Unfortunately your rules are still incorrect, as evidenced by the blocks from WOS.

We need to see a complete list of your Application and Global rules.

if you need to c more just say.

[attachment deleted by admin]

[attachment deleted by admin]

Everything I’ve read suggests you need the following:

* UDP 1200
* UDP 27000 to 27015
* TCP 27030 to 27039

Which is not what you have, so my guess is that port is not for CS.

If you’re sure your router is not interfering with CIS I suggest you add an ASK + Log rule, but first get rid of any rules you already have, including the global.