Not able to reinstall Time Machine

I recently tried to uninstall comodo time machine,using its own uninstall option not using windows or any other uninstall program,i have comodo program manager but i used the time machines own uninstall option.the uninstall failed, a message popped up but went away in a fraction of a second,the PC rebooted by its self so i thought it might be ok,and it seemed ok.until i tried to re-install it and now i get a message telling me i need to finish the uninstall before i can install it again,it is not listed anywhere on the PC,or in comodo program manager,it used to be but it is not now.i have used comodo system utilities to clean the pc & registry,even aggressive using heuristics.i tried everything.eventually i used my DVD’s made when the PC was new and reset the pc to manufacturers original setting,but somehow there must still be remnants of it on the PC somewhere because i still get the massage telling me to finish the uninstall.When i reset the PC it said all data on C: will be deleted,obviously it is not,as i still can’t install time machine again.i just don’t know how there can still be anything of the original install there a uninstall program just for time machine 2.8.24214.178 it is windows Vista home premium 32 after some more research i think i need this ClearMulOs.exe ,if someone knows where i can get it, i would be very gratefull.
I have even contacted Comodo help desk support suite, sent a ticket and their reply just tells me to come back here they won’t do anything more. But i can’t find where i can get this ClearMulOs.exe from except from other people on here have offered it to others in the past but no one seems to have it now to offer it to me

i have the same problem and I don’t know where is the application “ClearMulOs.exe” to solve this problem…

Please request it in You must restart your PC to finish installation….

Locking this topic for double posting.