No remember this option on some pop up alerts

It seems a bit old issue that I had faced in the past with Sandboxes like GeSWall, DefenceWall, SandBoxie etc and I did made a few posts and that issue was fixed in a newer version.

My old thread is here,680.0.html

I have got again a similar issue. I don,t get a remember this option for these alerts? It,s really annoying.

CAn it be fixed at least in the newer version. Thanks

First pop up I get when I want to see log of System Safety Monitor free in Firefox( no such pop up with IE and Opera, so no real problem but I just wanted to notify it).

Second pop up is when EQSecure tries to connect to get an update. again not a big deal as I can put it manual but again it,s an issue that need attention.

[attachment deleted by admin]

I guess there’s a reason for Comodo’s not letting you establish an unsafe rule?

Anyway something similar happened to me, try this:,9183.msg67023.html#msg67023

EDIT: However I don’t think it will help you since your programs “refuse communication” because they’re sandboxed out for CF’s reach. I understand that CF suspects fishy activity when the programs asking for connection refuse to communicate, that’s like a car not stopping at a police checkpoint.

I guess the best option would be that CF was inside the sandbox and thus could control what happened as it’s intended to? Haven’t tried sandboxing myself though.

The problem with SandBoxes is solved long ago. Ther problem here is with System Safety Monitor and EQSecure both of which are HIPS.

I also understand that CF suspects fishy activity when the programs asking for connection refuse to communicate but it,s my systrem and I want to let oit happens why CPF wants to enforce me not to do so?

There might be more and more applications that show some behaviour as their security feature and this bug might become really annoying for many of us.

I hope Comodo developing team will have a look to this issue.

I fully understand what you say, and I’m sorry if my first sentence sounded like a rude “DUH”, you may very well have understood it that way now that I re-read my post, but I assure you it was not my intention, it was really a guess and nothing else intended. I’m really a noob in this questions, only dared to post because I experieced a problem that sounded similar but most likely it wasn’t related. So I’m also hoping someone more informed will help you here. :slight_smile:

Hi no problems at all here. U were not rude at all. I was only making a point that if the user understands the meaning of these pop ups, he must get an option for remember this.

I submitted a support ticket.

Have you tried editing the concerned rules in the app monitor and checking “skip advanced security verification”? Still just guessing. :stuck_out_tongue:

As Egemen explained in the other thread, there is no “remember” option because the application in question refuses to communicate with Comodo; thus there is not a method for CFP to retain the information, as the application is not cooperating. The application itself will not be “remembered”; it’s not that Comodo wont’ remember it, it’s that the application will not allow it.

Was the issue ever resolved (as from your old post)? From that post it looks like it was left with the promise from Melih that they would look into it.


Hi, the first issue with sandboxed browsers was resolved since long as I made it clear in my post.

The second isssue is just new for me. BTW the explanation that SSM/ EQSecure is stopping Comodo from remembering the rule is difficult to swallow for me.

I will try it but it might decrease the security level for browser too low, not an acceptable option I think.

Checked it, it does not work.

Personally I feel the reason your seeing these messages is simply because the applications in question try to protect themselves, from being terminated.

Unfortunately, if they see CFP as a threat they are unlikely to send any inter-process communication, hence CFP believes they will not communicate.

That,s OK. I don,t complain for this. I just want a remember this option to get rid of this pop up again and again. It,s almost a non-issue for me at the moment but I posted it as the developers might change something in upcoming version to get a remember this option here if possible.