No password protection on entry to virtual functions. [M424/M263] [V6]

This issue has grown in 2847, so there is now no password protection on entry to virtual functions at all. This has been logged in tracker as new bug 424 and bug 263 has been retired as an incomplete duplicate. Appropriate action is currently being discussed in the tracker.

A. THE BUG/ISSUE (Varies from issue to issue)
[ol]- Summary - Give a clear summary in the topic title, NOT here.

  • Can U reproduce the problem & if so how reliably?: Yes reliably.
  • If U can, exact steps to reproduce. If not, exactly what U did & what happened:
  1. Enable password protection [Mod edit: using General Settings ~ User Interface]
  2. Run any virtual program from within the GUI, Sandbox Tasks, Run Virtual (Password is required to run virtual).
  3. Run virtual from a previously created shortcut (Even pre-defined shortcuts) to any program (Password not required).
  • If not obvious, what U expected to happen: I expected to see some uniform between the two different ways of running a virtual program, in regards to the password requirements.
  • If a software compatibility problem have U tried the conflict FAQ?: N/A.
  • Any software except CIS/OS involved? If so - name, & exact version: No.
  • Any other information, eg your guess at the cause, how U tried to fix it etc: My guess is, it is a design fault.
  • Always attach - Diagnostics file, Watch Activity process list, (dump if freeze/crash). If complex - CIS logs & config, screenshots, video, zipped program (not m’ware)

B. YOUR SETUP (Likely the same for each issue, so you can copy forward)
[ol]- Exact CIS version & configuration: V6.0.264710.2708, proactive.

  • Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV: CIS proactive defaults.
  • Have U made any other changes to the default config? (egs here.): No.
  • Have U updated (without uninstall) from a previous version of CIS: Yes, only from V6.0.260739.2674.
    [li]if so, have U tried a a clean reinstall - if not please do?: No but I will, only if necessary.
    [/li]- Have U imported a config from a previous version of CIS: No.
    [li]if so, have U tried a standard config - if not please do: N/A.
    [/li]- OS version, SP, 32/64 bit, UAC setting, account type, & VM used: Win 7, No SP, 32Bit, UAC off, Admin, No VM.
  • Other security/sandbox software a) currently installed b) installed since OS: a) None b) Previous versions of CIS.

[attachment deleted by admin]

Thank you very much for your report in standard format, with all information supplied. The care you have taken is much appreciated by Comodo, and will increase the likelihood that this bug can be fixed.

Developers may or may or may not communicate with you in the forum or by PM/IM, depending on time availability and need. Because you have supplied complete information they may be able to replicate and fix the bug without doing so.

Many thanks again


Not fixed in _2801.

Not fixed in _2813.

Can you please check and see if this is fixed with the newest version (6.2.282872.2847)? Please let us know whether it is fixed or you are still experiencing the problem.

Thank you.

PM sent.

Discussed via PM.

I think this bug should remain unfixed for present, please see my note at top of topic.

Best wishes


Thank you Mike and Chiron.

Not fixed in _2860.

Thanks. The tracker has been updated.

The devs have flagged this as fixed. Thus, I will move this to Resolved.

Please let me know if you are still experiencing the issue.

Thank you.