No Longer Getting Popups & Network Breaks After Removing All Application Rules

I am running Comodo Firewall v. on Windows 10 Pro 1909.18363.720 in Custom Ruleset mode; and for quite some time now, I have noticed that when I select all the application rules and then click on remove and then click OK to save it, it no longer pops up asking what to do and just blocks and breaks the whole network.

I have tried countless things, like restarting it, checking and unchecking various settings to see if any of them will reset it back to normal, nada. Even after restarting the machine, does not work. It have found that only when you brute stop and restart the services, it will begin to work again. Every time I need to clear out the rules, I dread this and hold my breath and still happens. Funny thing is that the systray icon is blinking away in going/coming directions like there is a ton of traffic but since nothing works and there is nothing in the log about it, not sure why the icon keeps updating like that but oh well least of the curiosities.

Is there an explanation, or anyone have noticed, or knows what is causing this and what the workaround is for it that is not as brutally inconvenient and blocking as how I am fixing it now? I have searched for it, and I don’t see anything about it but could have used the wrong words, I don’t know. And for those wondering why someone would do that, every so often I like to get a new start and clean out the rules for apps I don’t regularly. Regardless, if it should work, then it should work, no matter how we got there :slight_smile:

Just registered today to confirm that I am experiencing what appears to be the exact same problem. I had to do a full Windows reinstall yesterday. Everything worked fine until I installed Comodo Firewall. After that, all programs needing an internet access stopped working. After a bit of fiddling around I realized that all those programs ended up being listed in the “blocked applications” list, without prompting me about it like it is supposed to while in Custom Ruleset mode. I first assumed I was doing something wrong, so I tried resetting the firewall’s configuration several times, uninstalling/reinstalling the firewall and I even ended up doing another full reinstall of Windows, to no avail.

Strangely, unlike Maximón, I faced all those problems when using version 6870. When I started suspecting this was a problem with the firewall itself, I installed an older version, 6818, and everything got back to normal. To be sure, I uninstalled version 6818 and reinstalled version 6870, which confirmed I got the problem described only when using version 6870. Also version 6818 can’t be updated to 6870 using the built-in updater.

I found some recent posts on here with users who may be affected by this problem without even realizing it because rules are already set on their computers eg : here , here , or here.

Windows 10 Pro 64 1909 18363.720, Z97 platform.

Right now, I have disabled the firewall, nothing works but Edge (which confounds me how) and I do notice that some of the popups, like when you right click to change the state, pop and disappear instantly. So that may also be an issue, but why would it do that suddenly?

At this point I need to get this system running, it is for a student that cannot get any work done right now that everything is remote. So I have no choice but to uninstall it and deal with it some other time. I have dealt with this on my own system but not for a while, so this certainly sucked so far as timing.

At Maximón. I loaded a fresh Proactive Profile and activated it. Created a couple of rules and removed all Application Rules but I could not reproduce the issue.

If you reinstall CIS again see if the problem also happens when you start with a clean profile. We have to rule out your profile has gotten dirty over time.

At Couac your problem is likely different from Maximón’s problem.

Could you try installing the latest RC build 7036 and see if the problem persists there and when needed start a separate topic?

Or if you rather choose not to install a test build install 6882: : MEGA . Unfortunately Comodo does not keep a repository of older builds hence why you need to download it from a third party source.

Eric, I don’t know why but it happens quite a bit and I have a feeling some setting somewhere when set does this and only certain people are hitting it for that reason. Anyway, I uninstalled it this morning which pains me, but it had to be done. It just would not restore.

I’ll reinstall at some point but this has to stop happening, I can’t go through the whole process of install/uninstall like this every time it decides to suddenly block all internet and give you zero way to do anything about it.