No internet connection through garage software program

Can anyone help please. We have been using comodo for awhile no problems. We have recently started using a new program for our garage software which has been working fine with comodo untiil an update became available for the garage software. We downloaded it to our server and our client machine (we are using xp if that makes a difference) We still have access to the internet on both machines but when we go into the garage software on the server and try to use the dvla lookup option(which needs internet access) it says that there is no connection to the internet and check firewall setting. I have checked that this program has access and it does. I have found that in the pending files on the defense security option there are 439 files including files for the garage software that are listed as untrusted could this be the problem and how do I rectify it. Hope this makes sense and if anyone has any ideas I would be very grateful.

Hi Jo, welcome to the forums.

Can you confirm which Comodo product you have & its version, thanks. This section is for Comodo Online Backup and given what you’ve said, I suspect you’re talking about CIS (Comodo Internet Security).

[i]PS If it is CIS, then check CIS’s Firewall Events. Maybe someone said Block+Remember when the program was first run or perhaps it needs something special set-up. CIS’s Event Log should indicate what is happening anyway. Post screen shots if you need help with the Log. Also check to see if the program in question has logs.


Thanks for your post - you are right I am talking abour CIS. I’ve looked in Events section and under application it says ‘System’ and under Action it says Blocked. How do I change this setting to allow ? do you think this could cause the problem?
Thanks for your help

We have a network of two computers and use a garage software programme called Garage Assistant this is a new programme we are starting to use. This has been running fine with CIS until we performed an update for the garage assistant. We still have normal internet connection outside of the programme but when using the garage software on the server and try to access the internet for the DVLA lookup facillity it comes up with a message ‘no internet connection check firewall setting’. This only happens on the server, the client machine however, will access the internet throught the garage software. The defense mode is set to clean pc mode could this be the problem as this has only happened since we performed an update on garage assistant and if so how do I rectify it ? Before we performed the upgrade everything was working fine. (Ever wished you had left things as they were!) Any ideas?
Jo 88)

OK, first I’ll move this topic to the correct board (leaving a temporary place-holder behind).

You have blocks against “System”? Usually a program being blocked is named, unless the program in question is using System components. Can you post a screen shot of the blocks, thanks.

edit: Additional topic merged

Hi Kail

excuse my ignorance how do you do that ? I’m abit of a novice when it comes to computers !!!
Thanks very much

You may also wish to clear your “pending files” as these are not considered clean by CIS.

Go to Defence+/My pending files/First off hit the “Purge” button to clear any files no longer valid.
Now have a look through the list and select any that refer to Garage Assistant.You can now move them to “My own safe files” or just remove them from the list(note you are not removing them from your computer,just the list).You may get a pop up or 2 asking about these files.

Ok, this assumes you have no special software. Get the Firewall Events window up with the blocks showing. Either Maximize the Event screen or re-size the screen to ensure all the details are showing. Press the “PrtScn” button on your keyboard. This will take a copy of entire desktop to, what is called, the paste buffer. Hit the Start Button - Run & type “mspaint” (less the quotes). This will run MS Paint. Select menu Edit - Paste. This should have pasted your entire desktop picture into Paint. Tool bar on the right, hit the “Select” button. Select the stuff you want to post & menu Image - Crop. This should just leave what you selected. Finally, menu File - Save As (something.JPG). Don’t use BMP (they are very, very large).

On the forums use “Additional Options…” on the Post screen to browse & select your JPG file to post it into a reply.

I hope that helps, if not please ask. :slight_smile:

Hi Kail
Hope the screen shot is there. I have cleared what I think are garage assistant files from the pending section but I still have 251 files some of which may be GA is it ok to remove all of them?

[attachment deleted by admin]

Looking at your logs Joanne it looks like Garage assistant pro is being blocked by the Firewall.

Have a look under Firewall/Advanced/Network Security Policy–>In “Application Rules” you should have an entry listed as C:\Garage Assistant Server\FileMaker Pro.exe

What does the entry for it say(below is an example)

Try making C:\Garage Assistant Server\Filemaker Pro.exe a “Trusted Application”

To do this highlight the entry and then click “Edit”–>Check the box “Use a pre-defined policy” and then from the drop-down menu choose “Trusted Application”
APPLY to close all windows


[attachment deleted by admin]

Clarification: There seems to be 2 LAN IPs involved; & Can you tell me which IP is Event screen generated on & which IP is running GA. Also what is the relationship between the 2 IPs is & are both systems running CIS?

In addition, please check the Defense+ Event log & see if there are any GA related entries. If there are, please post a screen shot (no need to wrap the JPG file inside a DOC).

Matt: I think there might be more to GA than just Filemaker Pro, which seems to need an open port on 5003 TCP btw. Also, I think we need to understand the relationship between the 2 IPs. Both could be running GA & one is probably the Net gateway.

PS I’ll leave this with you Matt, call me if you need me. :slight_smile:

Thanks very much for the replies. I have changed the setting under appllication rules to ‘trusted application’ on both computers - they were set to custom. Still not working. We have two computers - IP is the machine which has internet access and IP uses it to gain internet access. For the GA program it works the other way around - IP goes through IP192.168.0.45 to access the GA software. Both computers are using CIS. The internet access problem is from IP when it goes through the GA software. The other computer is working fine. Both computers worked fine until i did an update for GA. The event screen was taken from IP I have enclosed the defense screen events which also is taken from this machine. Hope this makes sense.

[attachment deleted by admin]

Try putting in a Global rule on the computer which has IP to open port 5003 for TCP

Go to Firewall/Advanced/Computer Security Policy/Global Rules---->click “Add”

Action=Allow (check the box for logging)
Description=Garage assistant
Source Address= Single IP
Destination Address= Single IP
Source Port=Any
Destination Port–>A single port=5003

APPLY then OK to close

Move this rule to the top of your Global rules.

If this doent help ill ask Kail to add his expertise.

Hi Matty
Tried the global rule still not working
wait to hear from you

Something which may be worth trying is to go to application rules(on both computers) and remove any entries related to Garage Assistant, highlight the entry and select Remove then OK.Also remove the entry which is labelled System if there is one.

Re-boot both computers then right click on the Comodo icon in the taskbar and set the Firewall level to “Training Mode”(pic below).

Run the Garage assistant program, rules should be created for it.

Now reset the Firewall to whatever setting you had previously.

Also if you know the computer is clean(recent av scans have shown nothing) i would remove all the files from the pending list.
Sorry i cant be of more help, ill ask some of the more learned Mods to have a look if the above fails to rectify the problem.


[attachment deleted by admin]

Hello all,

In this case the fastest way to test if CIS firewall config(s) are blocking stuff is to temporary disable both firewall’s, test the software if it runs you know for sure it’s CIS firewall related, and of course enable firewall(s) again… otherwise you could be wasting time searching for a problem that is not there :wink:

Could you try that ?

Hi All

Thanks very much for all your help. It looks like this is not a comodo problem but something else (?!) stopping access at the garage software end. The program is going to be updated to sort the problem. Its nice to know that helpful people are out there. Thanks again

Hi Jo,

Thanks for the feedback !