No Internet connection and cannot send/recieve email [RESOLVED]


I hope someone can help. My partners machine was heavily infected with viruses, which after many days, I managed to clean. However, I found it impossible to reinstall ZoneAlarm so tried Comodo as it was highly rated. Before installing I was able to retrieve emails and had internet accesss.

Now nothing works. I cannot get internet connection nor retrieve emails. I have checked the network zones (have a Belkin wireless router) and set up as per instructions. I have scanned applications. I have made sure svchost.exe is allowed access out (it said somewhere on this forum that once out was allowed in was automatic).

Really don’t know what to do. I have (now) many antispyware and antivirus programs running including Superantispyware, AVG anti-spyware, SpywareBlaster and, although not active, Avira Anti Virus. All these were part of me trying to get the viruses off the system.

Machine runs Windows 2000 (yes, I know it’s old).

Can anyone please help?

I’m sorry if this has already been posted somewhere, but I have scoured the forums for answers and couldn’t find anything like this. I have checked (I think) all the new users FAQs and tips (and followed some of the advice, just in case), so sorry, in advance, if I am not looking in the right place.

Many thanks

Hi Andy. Welcome to the forum.

Viruses/malware have known to kill internet connections on its own, so in order to first determine if CFP is at fault:
Right-click on the CFP systray icon and Adjust Security Level to Allow All. Please note this is only a temporary test and you should immediately set it back to Custom.

If there’s still no internet then it’s something else. Here are some related threads:

Could it be possible that the previous installation of ZA was not completely uninstalled and some remnant is causing a problem with the CFP uinstallation?


Thanks Guys.

ZA wa not xompletely gone so I got rid of the last traces of it. The worry was that, even after uninstalling Comodo, I still had no internet access, which was a little firghtening. However, after my initial fears of a corrupt Winsock, I found that by running ipconfig /flushdns I got connectivity back and it was the only thing I needed to do. So I have reinstalled Comodo and now everything seems to be working OK.


Thanks again

Thats great andyatvanda,

I will mark this topic as resolved and lock it. If you want the topic re-opened please ask an available Moderator.