No inspect.sys on the System (3.0.8 & 3.0.9)


i tried to install the firewall but i always get the error that it can not find the “inspect.sys”.

I tried this Versions:

I searched the whole system (c:) but there is no inspect.sys
This did not work either:

I even created the folders

  • “c:\program files (x86)\Comodo\Firewall”
  • “c:\program files\Comodo\Firewall”
    to look if there are files copied into them when i hit the repair button.
    But they were left empty.

Can somebody help me?

Edit: I tried that on a fresh install of 64 Bit Windows.

Maybe this thread helps in anyway.

It seems that it does not help for my problem.

  • The inspect.sys is referenced multipe times in registry.
  • There are 3 .inf files in %windir% referencing “comodo”.
  • There are drivers installed containing the name “comodo”.


  • The file inspect.sys itself is not on the system at all (i searched the whole disk).

I started to test Comodo Firewall using 3.0.8. So no old files could exist. Nothing like Spybot S&D or any antivirus is installed. It is a fresh windows install containing only an Internet Explorer and an Explorer Alternative. The .NET Framework is installed too.

I made a new try and uninstalled it all again and created this folders:

  • “%programfiles(x86)%\Comodo\Firewall\Repair”
  • “%programfiles%\Comodo\Firewall\Repair”
  • “c:\Program Files (x86)\Comodo\Firewall\Repair”
  • “c:\Program Files\Comodo\Firewall\Repair”
    After that i installed it again but no inspect.sys was created on my system.

According to my problem and the problem reported in the last post the installer must be buggy. Did someone consider to use the standard way in windows? -->msi

To work around my problem:
Can somebody send me his/her inspect.sys file? (version 3.0.9)

[ol]- Boot in safemode

  • Unistall V3
  • Look for comodo drivers in Device Manager (see quote below)
  • Uninstall any comodo driver in Device manger
  • Remove any comodo inf file from windows\inf hidden directory
  • Remove any comodo driver (cmdGuard.sys,inspect.sys,cmdhlp.sys) from system64(or 32)\drivers
  • Search for any comodo folder and delete it
  • Search for cmdGuard.sys,inspect.sys,cmdhlp.sys in the registry and delete them
  • Install V3 Again
  • Look for comodo drivers in Device Manager (see quote below)
  • Look for comodo drivers (cmdGuard.sys,inspect.sys,cmdhlp.sys) in system64(or 32)\drivers and backup them
  • Reboot and cross fingers[/ol]

BTW Look in you windows directory for System32 and System64 folders do you have them both?
If you don’t have system32 folder try to create it