No FTP connections outward from either Filezilla or Dreamweaver

I love Comodo Firewall, but I can’t get it to connect thru any ftp software. I’ve tried Cute FTP - Filezilla - and Dreamweaver – all set to passive ftp. I have allowed all these applications, but they all time out. I’ve added them in Application monitor and allowed everything.

It does actually connect to the external site, but then times out. Any ideas – I’d hate to go back to my paid-for Zone Alarm!

Thanks heaps

These may help:


Hi –

I’m sorry, I’ve never had to use a help forum before, and I should have said I’d already searched through all the posts and been to the FAQs pages. Nothing there was any help. I’m trying to connect from an FTP CLIENT to the external server connection. Most of the posts relate to setting up an ftp server on a home webserver and most fdon’t have any applicable suggestions.

To simplify – even if I try thru firefox i.e. – I get a status bar message that says connected, but I’m not prompted for username:password.

The minute I turn Comodo off – ALL OF THESE ftp softwares work fine.

I’m missing the Comodo internal settings, but I’ve tried all the ones in the help suggestions.

Can anyone help a COmodo newbie to get this to work!! Please …

thanks, Cheryl


Everytime I want to use Dreamweaver or Filezilla I have to turn Comodo onto “allow All” — and as this happens 5 or 6 times a day, I often forget to turn it back to custom!!

Please can someone help me

Thanks Cheryl (:SAD)


You will need to have an Application Monitor rule for each FTP Client application you’re running locally.

You will also need to make sure that your Outbound Network Monitor rules are not specifying destination ports, since the port choice following the port 21 connection will vary widely.


Hi Little Mac-

Thanks heaps for your response - I really appreciate it. I’ve tried all sorts of things this morning.
Here’s what I’ve got now–

Filezilla (for example) :
Application: C:\Program Files\FileZilla Client\filezilla.exe
Parent Application: C:\WINDOWS\explorer.exe
[tick] allow all activities for this application

Network Control Rules:
ALLOW TCP or UDP in from ip 82.197.blah.111 to IP [Any] where source port is [Any] and destination port is [Any]

ALLOW TCP or UDP in from ip [Any] to IP 82.197.blah.111 where source port is [Any] and destination port is [Any]

Am I an idiot??? What am I missing … thanks again, Cheryl

I got it!! I got it!!

I read another post that showed where the logs are, and I found the culprit.
It has nothing to go with which ftp program I use - it had to do with svchost.exe & services.exe - which I had obviously blocked some time ago for some other reason !!! Once I deleted the block for these two, and reenabled them – off we go !! Yaaaay!

Thanks for all your help … (B)

Hee hee! Pesky little svchost.exe strikes again! ;D Glad you got that figured out.

BTW, you should not need any Inbound Network Monitor rules in order to download files via FTP. You just have to have something like the default Allow TCP/UDP Out Any Source/Destination IP, Any Source/Destination Port.

Reason is, your FTP client is making the Outbound request for the connection and download. So the responding download is because of that request; it’s not unsolicited. An Inbound NetMon rule is ONLY for unsolicited connections (like if you’re running an FTP Server).