No firewall alerts, All application rules set to custom by default.

Hello! Longtime Comodo Firewall user here. Since a while, my firewall is not showing me any network activity alerts anymore. Previously, when a program tried to initiate a connection, Comodo would notify me first with a host of options. Now, I do not get any notification and if I go in to the application settings, it shows me that Comodo set a “custom” ruleset for the programs that I launched which is pretty much allowing all connections. I can see new programs being added after I launch them with the same “custom” setting. The same goes with the HIPS alerts, I do not get them anymore and all programs get “custom ruleset” by default without asking me anything, unlike before. I tried different modes, safe mode training mode etc. to no avail. I do NOT have the “Do not show pop-up alerts” setting checked. I tried setting the “alert frequency” setting to “very high” but it did not make any difference. Just reinstalled all Comodo components twice, by removing with revouninstaller but nothing changes. Any help would be greatly appreciated. I am on windows 10 if that helps.

Create rules for safe applications is enabled, disable the option in both HIPS and firewall settings.

Hello, Thanks for the response. Create rules for safe applications is disabled in both components. I did try earlier to toggle that option but that did not change anything. Any other possible reasons?

Was HIPS and/or firewall set to training mode or silent mode when you launched these applications? I would try a clean re-install if issue persists.

They were not set to silent mode. While opening applications, I have used the training mode to test, but using training mode or safe mode does not have any effect on the alerts so far and everything sets to “custom ruleset” automatically in all modes. I tried to reinstall a couple times using RevoUninstaller and restarting and installing again with no effect. Are there any other ways to “clean” install? I was also trying to find a reset all settings button but couldn’t. Is Comodo somehow managing to retain my older settings?

You should use the official uninstaller tool. To restore default settings you can import the config you are using from the CIS installation folder, e.g. if your using proactive config use import and navigate to where CIS is installed and look for the proactive .cfgx file and overwrite the existing config of the same name.


Thanks for the help. I used the tool that you recommended to remove the installation. After a clean install, I also reset the settings to proactive like you showed. Hips now shows me notifications in paranoid mode but haven’t had any in the safe mode yet. After doing this the firewall is not making any new rules, but I can see that its still allowing connections (in view connections) and not prompting me with anything in the safe mode.

Safe mode will not show alerts for trusted rated applications only those that are rated as unknown or malicious, so it is working as intended.

I guess that sorts out the HIPS. I tried training mode for the firewall, still the same thing, connections are allowed and are automatically set to “Custom ruleset” again.

Why are you using training mode if you do not want rules to be automatically created?

From the help doc:

Training Mode : The firewall monitors network traffic and create automatic allow rules for all new applications until the security level is adjusted. You will not receive any alerts in 'Training Mode' mode. If you choose the 'Training Mode' setting, we advise that you are 100% sure that all applications installed on your computer are assigned the correct network access rights.

Well I don’t remember what mode I used to be in. But currently I tried all of these modes and I do not get any prompts so I’m trying them all. I am pretty sure I see applications that are not trusted rated being set to custom automatically. Thanks.

Was “Remember my answer” ticked on the alerts you got?