No connection to Teamviewer in LAN-Mode

Hello Comodo-Stuff,

i can’t connect to TeamViewer on my Notebook via LAN (PC to PC).
I’ve set the Firewall to “Training-Mode” so that the FW should informs me if there is a connection which needs my attention, but the FW is very quiet.

I also put “Teamviewer.exe” and “Teamviewer_service.exe” in the Whitelist, but without success.

I can only connect to Teamviewer if i set the FW to “Off” so it looks like it have something to do with the Comodo Internet Security Firewall.

Can you help me?

Best Regards,

You’ll have to set up a global rule to allow incoming traffic of the type & port number(s) required for team viewer, as well as application rules for the intended application listening for said connections.

I’m not familiar with TeamViewer, so I can’t help with the specific ports and protocols.

Tnx for you try, but because you are not familiar with it i will wait for a solution.

I have experience with Firewalls since 1998 and normaly i get a questione from the Firewall if a Programm wants to send or receive Data from an IP and a specific Port and then i need to accept it or not and then it will be set as a Rule.
The Comodo Internet Security Firewall did especialy this for a while but after some updates in the past from Comodo the FW is far too quirt.
It makes no matter if i set the alarm Level to Very High or Low…
This happens to all my 5 PCs.
Would be nicer if i can decide, what program wants to “talk” to the Internet with the “Response” from the FW which will ask me, what to do.
Also i miss a Log so that i can see, what Programm wants to connect to my Notebook (in this Case, the TeamViewer).

Maybe i need something to change in the Settings, but what?

Using Windows Firewall I found that 3 of the 4 Teamviewer executeables (.exe) were allowed though firewall. I was also getting no firewall notifications when trying to use Teamviewer in LAN only mode. Yet I could not connect in LAN access only mode.

Solution was to ADD teamviewer_service.exe (%ProgramFiles% (x86)\TeamViewer\Version8\TeamViewer_Service.exe) to firewall with allowed access… then I could even delete the firewall rules for the other three .exe’s and still be able to connect just fine.

This probably only applies if you set up Teamviewer to run as a service (i.e. to allow access “before windows starts”) which you might have done when installing the software without remembering doing so.

Teamviewer not connecting at the LAN mode occurs mostly when your internet connection has certain issues.

However, if you update to the latest version of the TeamViewer it might help you to solve the problem

There is a detailed guide on as to how you can utilize Teamviewer features at their best