new version, problem on start up??? [RESOLVED]

When windows starts the fire wall is initializing for a LONG time, a few minutes, ithe older version was 2 seconds. I then get a error message the fast user switching is not running, then it finally is on… any ideas?

Same here, what a dog. It takes about 3 minutes now for Comodo to start. A screen pops up and says something about “Can’t initialize session manager, fast switching not supported”.

This means it’s taking a while for your fast user switching to initialize. Firewalls monitor and have to wait for applications to load. You could turn off fast user switching but this is normal. You can read all about fast user switching here, learn how to disable, enable etc…I would do this…disable user switching, restart the pc…then reinable fast user switching, restart again. With two accounts, something may be getting gummed up from previous version and settings and doing this sometimes gives the firewall a fresh take on it, (to put it in very basic terms.) I have had to do this with ZA many times and always worked.

Hope this helps,


My fast user switching is set to ‘manual’ so it was not started…

By MANUAL I would assume you mean off? Where did you look for the settings?



Hi and thanks… under services (i disabled) the fast user switching service… I restarted and opened firefox and was typeing this when finally the error cant initialize session manager, and then something about fast user, I dont remember the exact message…

Thanks again

Ok, go to control pannel, click on user accounts, click change the way users log on or off, and see if the box for fast switching has a check in it. You should have used that instead. I would re-enable it in services and use control pannel. Otherwise there is another issue here.


Ok, I checked and it was NOT checked. I checked it and under services set fast user switching, terminal services and rpc to auto instead of disabled and it works great now!!!


You are very welcome!



Mines fixed also, I set fast user switching and terminal services to automatic. Fixed.

Good to hear.

Take care,


If a use has done a normal install of XP PRo without disabling any services or changing the state of them, will this problem occur?

cheers, rotty

Hi rotty, it shouldn’t. I am stating this not just for you but for others who are concerned about getting a said issue that they see here, so please take no offense, as there is none intended. What I see is this, many many users have downloaded the new CPF, when problems occur, they get attention here. This doesn’t mean it will happen to everyone and a vast majority don’t always have issues at all or a little. From what I see on the forums is X amount of people getting certain X amount of issues but that leaves a vast majority who don’t. There are different circumstances on each and every PC due mostly to different programs\updates\registries, etc…and out of X amount of people with problems, X amount may not be truthful, or even know what’s truly going on. So while it may seem like this problem is right there in front of you due to being on here, I would guess your chances of having this are very slim. Those who don’t have issues typically don’t return or post it seems which makes sense in a way. I wouldn’t worry and even so, just do what I posted above and you should be fine.
Hope you understand what I mean :wink:



I’m having similar problems here with the new version, the latest BETA didn’t suffer any of the here mentioned problems. I’m running Win XP Pro SP2 with all security patches and updates installed.

I have fast user switching enabled in the control pannel (both my wife and I share the same computer).
My services for Fast User Switching and Terminal Services are set to Manual which is XP’s default as far as I know.
When XP is booted and I log on to my system is unresponsive for about 2 minutes, and the CPF system icon’s tooltip is mentioning that CPF is initializing. After 2 minutes CPF is initialized and my system is responding again and I can work as normally.

I changed the services for Fast User Switching and Terminal Services to Automatic to check if it makes any difference. After I log on after a few seconds CPF is now up and running but the rest of my system keeps unresponsive for about 2 minutes, after that everything works OK.

Although the new version works like a charm for me it is very annoying that everytime I boot up my computer I need to wait for 2 extra minutes before I can do anything. Hopefully the next version can fix this problem once and for all.

Hi RichZ, While I do sympathize with you, not everyone has this problem and it may only be on certain systems with certain configurations\registries\programs. If it was a global issue with CPF , almost all of us would have it as well. I would also worry a bit if my firewall came up instantanioulsly, what in fact would it be scanning for then? Other than that, what has been showing up as well, is people have other software or securities that aren’t mixing well. I would think you have XP firewall disabled in BOTH accounts? The advanced, LAN unchecked as well? You can also use msconfig typed in the run box to disable some startup items and see what may be causing \contributing to the cause of this slow startup. To be honest, I don’t find it that bad, ZA used to take 10 minutes at times. Talk about grab some coffee and relax. But at the same time I realize this is a bother to you. I would try some basics first, check for spyware, etc…do a disk clean up, disk defragment, perhaps download Ccleaner for basic reg and other garbage files, does a great job, easy to use. If doesn’t help, post back to use MSCONFIG to find where the startup hog is.



I’m scared to install 2.3.4 now because 2.3.3beta works like a charm here. :expressionless:

I have been busy checking if I can find out what the problem is on my machine. I have been systematically disabling (non Microsoft) services to see if it helps. So far I have found out that if I disable all services that depend on the Remote Procedure Call (RPC) service my PC works OK; CPF starts immediately and I can instantly start working on my machine. I can not determine (yet) what service or combination of services causes problems with CPF but I’ll keep investigating and report back if I find out something. The services on my machine that depend on the RPC service are from AVG (virusscanner), Diskeeper (defragmenter), LogMeIn (Remote Access) and a VMWare service.

The above solution does not always work, I just had to CTRL-ALT-DELETE and kill the CPF process by hand because my system did not respond after 5 minutes.