New version 3.5.55810.432 still hogging 100% processor!

According to Comodo website, the CPU hog with Firefox is supposed to have been resolved with the new v3.5.55810.432. This is not true. I am running that version and am STILL getting the problem. I’m using Windows XP (SP3).

It seems that the developers can’t solve it so they pretend they have, and then close and lock the ‘Bug Report’ section so that new contributions or complaints cannot be added.

Comodo have had this problem for months and not provided a solution. I’ve now had enough of this, so I’m off to look for something else, very likely ZoneAlarm, and going to be removing it from my PC. According to the reviews I’ve been reading, ZoneAlarm is getting higher ratings than Comodo, which used to be a good, but no longer.

Good riddance to useless rubbish.

Sorry you’re still having trouble, but…

…accusing the developers for such things doesn’t seem fair to me.


I think I was rightly feeling fed up with the issue. However, shortly after posting my last entry I decided to try something else and ended up solving the problem. I suggest others having the same problem follow the same route.

I list instructions below to make it easy to follow. Please excuse the simplistic explanations, but I include these for the benefit of those who are not so proficient with compputers. By the way, my Windows XP is set to ‘Classic View’. I imagine this should work for Windows Vista too.

  1. Go to Comodo website. Download and save the latest version installation program to somewhere on the hard drive, eg. C: or in ‘My Documents’. If you don’t have CCleaner, also download and install that from

  2. Disconnect from the internet by either switching the modem off or taking the lead out.

  3. Go to Start> Programs> Comodo> Comodo Internet Security> Uninstall or Upgrade, and uninstall Comodo. If this is missing from the Start Menu, launch the new Comodo installation program. After it unpacks and launches it will detect a previous installation of Comodo and ask if you want to remove this first. Select ‘Yes’. After it’s uninstalled, the start of the new installation process will appear. At this point, close the Comodo installation program down.

  4. Restart Windows and go into Safe Mode. This is done by continually clicking F8 during start-up. A dialogue box may appear asking which device you wish to boot from - just select the first hard drive on the list. When the System Restore question appears, Select ‘No’. You’ll know you are in Safe Mode if the icons are very large and it says ‘Safe Mode’ in the four corners of the desktop.

  5. Click on ‘My Computer’ and navigate to C:\ Program Files. Open the Program Files folder. Locate the Comodo folder and delete by right-clicking it and selecting ‘Delete’ from the drop-down menu. This will ensure all old files are completely removed. You can’t do this in normal mode because there is a file that will refuse to delete.

  6. Restart Windows and boot back into normal mode. Empty the Recycle Bin (or at least delete the Comodo folder in it).

  7. Run CCleaner. In the left hand pane of CCleaner, select ‘Registry’ and click ‘Scan For Issues’. A number of issues will appear listed, including ones for Comodo. These are left-over registry entries that can no longer find the files that you deleted. Click on ‘Fix Selected Issues’. When asked if you want to back up changes in the registry select ‘No’ and proceed to delete. When this is done, repeat the procedure again and again until CCleaner finds no more registry problems. Close CCleaner.

  8. Restart Windows and proceed to install the latest version of Comodo from the downloaded file and all will be okay.

In my experience, everytime comodo updated, it only replaced a few files. It has nothing to do with the registry. One time I even replaced some files manually to update.

Yes, and the Comodo uninstaller is very poor too, completely half-baked. When I tried uninstalling the firewall and restarted my PC, I got a Comodo alert box banging in telling me it couldn’t find some file. That is not a proper uninstall.The developers need to sort out this appalling inadequacy - it could really freak new computer users out not knowing how to sort this out. Unless it’s a deliberate means of keeping them, that is.

I’ve never had a chance to use the comodo uninstaller, but I thought it’s a common thing, because this kind of app which is deeply rooted in the OS, sometimes is hard to remove. It seems like you were testing some different firewalls, If you only want to update, there is no need to uninstall it and then reinstall it.

No, not quite. I had already performed a normal update of Comodo when it continued to show problems. I had also tried a standard re-install over the previous one with no improvement. I also tried an automatic uninstall - reinstall using the lastest downloaded package, but to no avail. I then did a straightforward uninstall using the latest downloaded package, and installed Zone Alarm. All seemed okay, although I wasn’t happy about the lack of a couple of features, but next day, for some reason, after starting up I was unable to obtain internet connectivity, even by switching Zone Alarm off. I performed a System Restore back 2 days, switched on Windows Firewall, and connectivity was returned. Zone Alarm’s installation was now effectively removed by Restore. I did a re-installation of Comodo but the CPU hog after I started Firefox returned. So this time I uninstalled Comodo and did what I outlined in my earlier post above. This solved the problem.

Maybe an update screwed my registry or corrupted a file, I don’t know. Surely it should be possible for the Uninstaller to remove ALL references in the registry, AND delete the Comodo directory, rather than leave it just sitting there? When I uninstalled Comodo the first time, I kept getting a box with the Comodo logo banging in with the usual ‘dong’ sound, advising that Comodo was unable to find some file. This is inadequate uninstallation.

Before you installed Zone Alarm, you “did a straightforward uninstall using the latest downloaded package”. was that uninstallation thorough? at that time you didn’t use the method you outlined.
You said you “performed a System Restore” ,what kind of tools were you using? the System Restore with the windows? I think maybe this is the source of the problem, windows system restore can not properly restore you system. If you want to restore you system thoroughly, I recommend Ghost.

Have you guys tired the new build .439 with a clean install?


I would have thought it was supposed to be thorough, although it actually wasn’t. As I had explained, Comodo had vanished from the Start menu, was not appearing in Add/Remove Programs, and an Uninstall program was not present in the Comodo directory either. Now I have a fresh install I’ve found that the program needed was cfpcnfg.exe. However, for reasons I don’t understand, after attempting to run this directly I notice it refuses to open anyway, whereas it does when accessed via the Start menu. So if, as happened in my case, where Comodo had vanished from the Start menu, I was stuck.

I used System Restore as supplied with XP. This would obviously not be related to the CPU hog problem but, as you say, may be related to the uninstall problem - I don’t know. Unfortunately, it’s too late to check now. However, thanks for your suggestion of Ghost, which I shall look into.

No. Having just checked the Comodo website, it’s still at .432 , so I don’t know where your .439 came from.

32 bit XP & Vista:

64 bit XP & Vista: