New install caused Win XP to appear frozen

I’ve been using AVG Pro with their firewall for the last several months with good results. However, I’d read several reviews about the Comodo Firewall that made me download it. As I surveyed the site, I saw the Antivirus and decided to try that as well. I am running Windows XP Pro SP 2 on an AMD Athlon 1.4 GHz system with 1 GB of RAM. I’m a systems consultant so I’m used to installing and uninstalling applications and am aware of the problems they can bring… especially if they’re still beta.

After completely uninstalling AVG w/Firewall, I installed Comodo AV 1.1 (beta). The install appeared to go just fine. However, after rebooting the system, it slowed to a crawl. The only reason I knew it wasn’t frozen was because the cursor moved. However, everything else was so slow that it appeared frozen. I tried several reboots and cold boots only to have the same thing occur. In fact, the only way I could get the system to shutdown/reboot was to manually shut it down. After the first reboot, the system was so slow it didn’t even get to the explorer screen. I tried uninstalling it in Safe Mode but that failed due to an issue with the Windows Installer and Safe Mode. I finally resorted to using System Restore from Safe Mode. That brought my system back to the pre-Comodo mode. I’m tempted to try the install once more, but this is my production machine. I’m also wondering if I’ll have similar issues with the Comodo Firewall.

Any help whatsoever would be greatly appreciated!


I have just had similar, but slightly different, problems.

I installed CPF and all went well. Left CAv for a few days, while I learnt about CPF.

Decided to install CAV, but I wanted to just be on the PC - I did NOT want it to be active, just to do scans on demand - and left the current AV application (AVG) installed and as the resident app.

Re-booted after the CAV install and my PC ran like yours. Well, “crawled” would be a better word. The mouse was quite responsive, but I could click on a window and it would take over 20 minutes to become active. After 2 hours of trying to shut down, lost patience and just turned it off. MISTAKE.

More than 12 hours later, I’ve re-built and am back on-line again. Windows wouldn’t start as, it said, the HAL.DLL file was missing or corrupt. I’ve totally de-installed AVG, and re-installed CPF and CAV, and all seems well. So far.

There does seem to be a problem: Comodo products (well, CPF and CAV) and AVG are not happy together - there are some threads in this forum about the problem, but it’s 5:30am and I can’t be bothered looking for them now.

The simple answer seems to be: don’t have AVG and Comodo products on the same PC.

[Edit] To get into World Cup fever … Go, Aussie, GO! (WCF3)


There have been several reports about PCs running exceptinally slowly after uninstalling an AV app and installing CAV, but these have been primarily McAffee and Nortons. Apparently both of these apps do not fully uninstall and leave registry entries and active processes behind.

I’ve never had a problem with AVG uninstalling correctly, but then again,I’ve never had to remove it and replace it with another vendors app - it was always old AVG out, new AVG in.

Have a snoop around the registry and see what you can find, generate a Hijack This log and email the lot to Include any relevant technical details on your PC that you think may help the support guys.

Hope this helps,
Ewen :-
(WCF3)- Ditto on the Socceroos - OI OI OI!

CAV from my experience cannot coexist with other AV programs. I have checked it with norton, mcafee, nod32 and pc-cillin. For the time being it seems impossible to have CAV and another antivirus installed at the same time.

Hey Pandlouk,

Not necesarily so, my friend. I’ve got CAV running in conjunction with AVG, but AVG’s resident component is turned off.

I believe the problem is caused when you have two on access components running at the same time. Each will be detecting the other checking a file when it is accessed and then will check the access for itself. This will, in turn, cause the first checker to detect the the second checkers access and check it again - ad infinitum.

Try uninstalling CAV, disabling the on access component of the other AV app, reboot and then reinstall CAV. You should find this works - it did for me, anyway.

Hope this helps,
Ewen :slight_smile:

hey guys i have the same problem about the “freeze”.almost 2 weeks,i,ve install CAV in my computer,after install xp sp2,and after reboot,my coputer becomes freeze, the mouse,the windows,the florders didn’t response,so the only way to repair it,was delete all my harddisk and install xp sp2 again.

Hi… Mine likes to run really slow if my screensaver comes up while CAV is doing a scan. It takes ages just to get back to my main screen. I know that the last update was primarily an interim one but do send all of your issues to the support people. I think it’s still a month before CAV 2 comes out which will hopefully fix these problems… read the Wish List Topic…


I had a similar experience with the person in the first post. I have an old laptop that was recently formatted with a fresh install of Win XP SP2. CAV was the first product I installed on it. Was installed it almost immediately froze windows up on me. I eventually got it to come up to the registration screen after first booting in safe mode but it only locked up again. I actually wiped the machine and tried again thinking maybe something had gotten corrupted with the new install. Reinstalled CAV and got the exact same results. I thought that might rule out any or some thoughts of it fighting with installed applications.

Yes. I met the same problem. I have a brand new XP installed (not SP2) yesterday and then installed CPF and CAV. The CPF is fine. But afer install CAV and reboot, the system act exactly as many other described. The mouse pointer moves but cannot run any process even ctrl-alt-del doesnot work. I restarted. But still the same. I restared again to safe mode and set the cav service to be disabled from the component service and restarted. This time my windows was back. I tried to manual restart cav service in the component service and no problem at all. Seems the only problem happens during the windows starting stage. I did some more testing and found that if I stop/delete the process of cavasm.exe when it first start, the system works fine. Otherwise, the system broke. Also, I have the feeling (not no proof) that the frozen is related to network connections. W/o network, it froze everytime. W/ network connection, I got through several times.