Network Shares Issues [Merged Threads]

Hello guys, I just installed Comodo 3 after uninstalling 2.4, on my main PC using WinXP SP2. I also have a PC working as gateway, also with XP SP2 and still with Comodo 2.4, connected to Internet thru ADSL. ICS is used to give Internet access to main PC, and it is working fine.

On my main PC I configured its network as not trusted, since Internet traffic uses it. Then I configured my LAN IP range as trusted (see picture 1). Before setting this config I was able to use Remote Desktop Connection to access the gateway, but gateway wasn’t able to ping the main PC. After configuring ping is back working.

But I’m still not able to acess shared folders from any PC to any PC, it is all blocked. Looking on firewall events (picture 2), there are lots of events originated from gateway that are being blocked, using the application System and destination port 137.

So I made the same config to System (picture 3), but still no success.

Anybody know what else I can do to fix it?

[attachment deleted by admin]

Did you set destination as port 137? I only see you setting up source.

When the source is the IP Mask, destination IP, source port and destination port are set to Any.

I am new to this , printer prints from this pc with comodo on it . Not from another pc on network ~I can’t figure out how to configure to do this.

I use Windows Vista Home Premium and just installed Comodo Firewall 3. I can no longer connect to the printer on my secondary computer. How can I fix this?


Ive installed the 3.0 version of Comodo firewall and now i cant Access my Pc from my Xbox mediacenter ive jused to stream movies and copy files , now it takes about 10 seconds and it shows an empty
smb: folder.
tried to add it to My Network Zones and open port 445 .
but nothing Works…

I got almost the same problem. I can only view the shared folders of my pc from xbmc but I can’t go inside the folders themselves.

With version 3 I have started having an issue with the network drive re-connecting. I have my network placed in the trusted zones but when I start my computer most of the time I can not access the network shares. If I disable the firewall and than immediately re-enable the firewall I have access to the network drives.

Everything else appears to be working fine with me. No major slowdowns with MS visual studio builds, No problems with BOClean, No issues with CPU , ect…

Any ideas on how to resolve this issue?


I had a similar problem with network shares not being recognized for 2 out of 5 drives on my system. Disabling the both the firewall and HIPS failed to fix the problem. I also tried deleting all the predefined rules as someone suggested but that didn’t fix the problem either. The only solution that worked was to uninstall V3. I used the uninstall link in the Start Menu Comodo program group and it worked fine. I reinstalled and uninstalled V3 several times trying various workarounds but I finally gave up and reinstalled V2 which works well. My system is running WinXP Pro +SP2 on an AMD X2 processor.

Ever since I installed Comodo Personal firewall V3 which has been fine on this machine, my other machines cannot access the Internet even though Comodo added the IP to the trusted network zones after the install. The other machines are using Windows Firewall because It’s not necessary for comodo on these machines.

Windows XP Home Edition using Internet Connection Sharing and a Workgroup to share files.

Another thing is that I can’t access my network shares on the other machines. Please could have some advice on this.

Thanks In Advance.

Same problem with home network using workgroup. Can see files on each pc but client pc cannot access internet. Any help appreciated

I tried ver 4 and had the same issue… A few people have also had this issue… I’m sure it will be worked out soon if it is a bug. But i’m not sure it is. Either way (B)

Same problem here. Win XP SP2 connected directly to cable modem. Created new trusted network when it asked, and ticked the box to allow sharing. I can share but the clien pc, via netgear router, cant access the internet. Back to v2 for me 2

I am using an xp pc with the new version 3 firewall connected via LAN to a wireless router. I am also using a Vista laptop via wireless to access the xp machine in order to use its printer. This worked ok on version 2.4 as I used the trusted zone wizard however afer version3 the laptop cannot see the xp machine. How do I configure the firewall to enable this in the new version please?

Since I upgraded to v3, I have not been able to print to my network printer (HP dj 6128). I can see from the log that it is being blocked for inbound access, but I can access the printer management fine from my browser.

Any thoughts?

I recently upgraded to v3 and it works great. The only problem I’m having is that now all the printers I had installed are gone. I tried changing the stealth ports settings to Alert me to incoming connections but it won’t stay.

I tried reinstalling the printers but the port won’t show, it seems blocked.

Any thoughts?

I assume these are network printers??? If so, have you set up a zone to cover your LAN and allowed traffic to/from that zone?

Have a bo-peep at

Hope this helps,
Ewen :slight_smile:

So, I would like to print from my notebook to my Xerox Phaser attached with USB to my desktop PC. There is XP Professional on the desktop, and Vista Home on the notebook, and they are connected by a mini-switch. Booth PCs runs Comodo Printing is working while Comodo Firewalls off. How can I print with turned on Comodos?

Please anyone, help me! (:SAD)

I am guessing that you need to define a home network IP address range. Your details about the connections are a bit fuzzy - how is the printer connected? Are you connected to the internet via a router - modem - switch. For some info on defining your LAN, see the help file: open Explorer and go to C:\Program Files\Comodo\Firewall and double-click CFP.chm. Then click on the Contents tab and then on the + beside Firewall Task Center and then on My Network Zones. Add your LAN to a zone, or add each of the devices’ MAC’s (both computers, the printer, any other peripherals with a MAC) to a zone and use the zone so defined to run the Stealth Ports Wizard (Help file>Firewall Task Center>Stealth Ports Wizard. That should define your home LAN zone well enough to allow you to print. Note, until the bug-fix, the help file cannot be accessed from the program directly.