Network Printer not being allowed

Does anyone know how I can get my network printer to work with CIS 6? It will work now only if I disable the firewall.
XP 32bit.CIS 6


What kind of printer do you have? Also, are there any log entries.

Thanks for answering me Radaghast.

My printer is a HP Deskjet 3510 - 3 in one. I searched for log entries but could not find anything at all pertaining to this.


It is connected via wireless and worked well with CIS 5.12

Hi John, unfortunately, I’m not having a lot of luck reproducing the problem. Granted, my printer is no an HP, but it’s still networked. So:

  1. Are there any drivers need for installation on the PC?
  2. What happens when you go through the ‘find printer’ routine from any application?
  3. What do you have by way of firewall rules - Application and Global

Hi Radaghast

  1. I do have drivers that were installed from a cd while I still had CIS 5.
  2. The printer is “not found” when the firewall is turned on.
  3. Firewall rules: see screen shots.

Thanks - John

[attachment deleted by admin]

I tried revising the application rules to make them as broad as possible but to no avail. It still does not print although the HP diagnostics says that it is connected. It is not


[attachment deleted by admin]

Without a networked HP printer to experiment on it’s a bit difficult for us to ‘play’.

Have you tried looking through online HP documentation? I’ve just typed ‘ “printer not found” firewall’ into Google and it lists lots of different support articles ranging from unchecking the Block Fragmented IP datagrams checkbox in advanced settings, to allowing UDP Port 427 (Service Location Protocol).

Maybe they will give you some things to try?

I wonder if this is a wireless issue, as my printer is wired…

I noticed you have logging enabled for the printer rules, do these generate any log entries when you attempt to print?

It might be helpful if you could also enable logging on the system process LAN rules, Global LAN rules, the Allow IP out and the Block in Global rules, see if any log entries are generated.

I don’t know about HP, but some printers requite SNMP and the spoolsvc to play a part during access.

By the by, what is your custom svchost rule for, something to do with your router?

Answer to the custom svchost rule - yes it is for the router.

I enabled the logging to see if I could get anything from them. I will uninstall all drivers and start from a clear slate and hopefully I will get at least an alert that I can approve.

I will let you know what happens with that.

I will also enable the other logging you suggest.


Reinstallation of the drivers accomplished the results that I was looking for. Somehow the drivers did not get approved during the installation process of CIS and the result was they were considered dangerous and were blocked.

Thank you my friend for your interest and help.


I’m glad you found the solution John :-TU