Network Magic

I am having trouble with Comodo and my Network Magic networking tool. I have added rules to allow the ports that Network Magic uses and set up a zone for my Network but I can not use the shared files capability and not sure what else is blocked. I at first had difficulty with Remote Desktop. Got that working but was concerned about the security from my rules so deleted Comodo and reinstalled. Can use Remote Desktop but have problems with sharing established by Network Magic.

I have a desktop pc with a linksys router. PC is connected to the router and my laptop is connected by wireless.

Attached is my rules as a JPG file.

Any help with Network Magic will be appreciated.

[attachment deleted by admin]

Welcome to the forums bill78759 :slight_smile:

Can’t say I know anything about Network Magic, but there is a KB article on their site here:

Firewall Configuration

regarding firewall settings.

Hope this helps.


Thanks for the response. The discussion on firewalls on their website covers a number of firewall programs but unfortunately not Comodo. The outlines for a generic firewall did not help. I have posted a question in their forum and am heading their now to check responses. I will advise what I find.


Ok :slight_smile:

If you don’t have any luck, I’m sure we can come up with a rule set that will help…


It may not be related, but Network Magic has been discussed before…,6018.msg44368.html#msg44368

Hope that will help,


I reviewed the posts and will try some of the ideas, however the final solution to the problem was a reinstall of the PC and I don’t relish doing that right now. May also look at some of the solutions in the Network Magic discussion to see if some of the rules for other rule based programs have any suggestions.

I am also wondering why I am getting some many pop ups for Firefox even after allowing and checking the box to remember.


The application alerts are going to depend on what exactly is in them. If you have your alert frequency set to Medium or higher, you are going to generate more specific alerts, and thus more specific rules (mtuliple rules will be created, each one a little different).

I have seen, I think, two cases where there were actually multiple exact duplicate rules; every other instance ends up that the alerts, and created rules, are all slightly different. The devil’s in the details, as they say…

Looking at the Network Magic site’s instrucitons, you will need to do a couple things in CFP:

  1. Add Nmsrvc.exe to the Application Monitor (you’ll have to navigate to the path; you can’t just type it in). Allow In/Out TCP/UDP. Under the Miscellaneous tab, select “Ski pAdvanced Secuiryt checks.” OK. May need to also do “Allow Invisible Connections,” but I’d just start with the one.

  2. Go to Security/Tasks, and Add a Zone. It will default to the address range for your entire subnet; that’s probably fine for the moment. (If you know the IPs of all computers and the router, you can set it for that instead.)

  3. Go to Security/Tasks, and Define a New Trusted Network. Use the Zone you’ve created. This will add two rules to the Network Monitor, at the top. The first one will Allow IP Out from Any to the Zone; teh second will Allow IP In from the Zone to Any. This will allow unimpeded traffic/communication between all your PCs and router.

Reboot to clear the memory and set the rules. Based on their info, that should do it. If it uses a specific port, that might have to be added, but it doesn’t look like it at this point.


Thanks for the reply. I have tried your suggestions and haven’t really time to check if that solved the problem. My latest problem was a conflict between Comodo and Qucken. Quicken was slow starting for a while and I took it to be Quicken, however now Quicken freezes during the start up and I have to restart XP to get back where I can use the computer. I searched the Forum and found only one discussion and that was not the problem I am having. Comodo did not have any thing in the log and it never came up and ask for permission for Quicken to run. I made Quicken a trusted application. I was not sure Comodo was the problem so started DrWatson with no entry in the log for the lock up. Finally, I exited Comodo and tried Quicken and it started with no problem. I am going to look on the Quicken web site and if I do not find a solution I will have to uninstall Comodo and go back to ZA (:SAD). I may try Comodo again after I get through with my taxes but don’t have time to tinker with a program as basic as a firewall right now.

Thanks for responses.


I have both Quicken and TurboTax installed with CFP, and have not had any issues. CFP alerts me when they want to connect, and I either allow or deny. I have not checked “remember” for either, as I do not want rules created for them on a more permanent basis. Neither one needs special Network Monitor rules in my experience, and unless you have at some point inadvertently created a blocking rule in the Application Monitor (you might check to see) you shouldn’t have any problems.

Since you are having problems, there’s obviously something going on. It should be easy to find and resolve, and we can help you with that.


Ok, guys…Until I hit Comodo, I thought I was PC savvy…Im at a total loss…I cant find anything mentioned that I recognize. I love the thoroughness of Comodo’s firewall, but if I cant access shared folders, I’ll have to use something a bit more straight forward.
Can you break down the paths for a layman?
Thanks in advance.

Just to make sure - are you using version 2 or version 3 of Comodo’s firewall?

You’ve posted in the V2 board and, although V2 is still supported, most users, O/S allowing, have migrated to V3.

Ewen :slight_smile:

Did you make sure to add all of Pure Networks Platform Services, and not just one or two of them? When using Comodo to search for a list of programs to add as safe to your firewall (most firewalls have settings for specific program control), the service you’re looking for is sometimes called “Pure Networks Platform Service” or as “Nmsrvc.exe”. If Comodo is not showing it in the list, you can add them manually.

The programs to add are located here:

"C:\Program Files\Common Files\Pure Networks Shared\Platform\nmsrvc.exe"

"C:\Program Files\Common Files\Pure Networks Shared\Platform\nmapp.exe"

"C:\Program Files\Common Files\Pure Networks Shared\Platform\nmctxth.exe"

b) Set Pure Networks software to "Fully-Trusted" or "Fully-Permitted".

If you only added one of the programs to your safe list of programs in Comodo, this may be why the issue is still happening. Hope this helps!