"Network firewall not functioning properly"

I just finished upgrading to the newest version of the Comodo firewall. I notice that the icon in the system tray has a exclamation point over it and there is a notation “Summaryl” page that says the network firewall is not functioning properly. I clicked the link to run diagnostics and selected the “Fix it” option.

As I expected, the replay came back that not all of the problems could be repaired. I expected that this would happen if I tried to upgrade. Now I have a non-functioning firewall and I have absolutely no idea what to do about it other than switch to MS Security Essentials.

I installed the plain vanilla version of the firewall and did not select to use DNS servers because I don’t know what they are. I have changed nothing except to move the slider on the “Firewall Security Level” from “disabled” to “Safe mode”.

Any suggestions?

Does the problem persist after a reboot?

If so, this thread by Ronny may be of help:
What can i do to fix “The Network Firewall is not functioning properly” ?

I didn’t try a reboot after the installation. I used instructions I had received from someone in this forum some time ago:

  • uninstall with Revo Uninstaller set to “moderate”
  • reboot
  • install new version

Nothing was mentioned about a second reboot. I’ve used yesterday’s system restore point to revert to the previous version while I decide if I want to try again or just go to Security Essentials.

I read the link you posted. It is completely over my head. Nothing should be so difficult to install properly as to require 3 pages of “what ifs” just to address one problem.

uninstall CIS you have after you have uninstalled CIS Look here


I did uninstall the firewall I have when I first tried to upgrade… used Revo set to moderate.

I started reading the link you posted and it just way too complicated for me to understand. I stopped reading on page 4. If the normal methods of removing the old version aren’t sufficient to allow trouble free installation of the new version, then it’s the Comodo Group’s responsibility to devise a tool that does the job without forcing me to get an advanced degree in computer science.


I’m sad to hear that you are having trouble.

Maybe I can Help a little bit more


Extract to the desktop

Follow these instructions

  1. Create a System Restore Point

  2. Go to the Control Panel->Add/Remove Programs, and launch the uninstaller for Comodo Internet Security
    If Not Done So Already

  3. Reboot in Safe Mode!
    Tap F8 During Restart, You’ll get Boot Advance Options
    Choose Safe Mode

  4. Run the CIS Clean-up Tool

  5. Reboot

  6. Run the CIS Clean-up Tool again, to make sure that files previously locked by the system are removed

All remaining files and registry entries for Comodo Internet Security should now be gone![/qoute]
If you have Vista/7 I would recommend Right clicking the File “CIS Clean-up Tool” Run As Admin.

Did this help you?


I have no love of zip files. Anytime I open one Windows extracts the files to somewhere I can’t find them. I normally save downloads to my desktop. How can I get the extracted files to a place I can locate? When I extract the files will it be obvious which one I am supposed to open to run the clean-up tool?

I have never played in safe mode: I understand how to get into it but I don’t know how to get out of it. Now suppose I do all this. I assume that after it’s done I can try and install the new firewall file which is also now on my desktop. Do I have to do this in safe mode? Do I have to restart after I install the new version?

When I tried this earlier today, the restore point created by Revo wouldn’t work properly and I had to go back a few days to find one that did. How long can I continue to use v. 3.5.5473.427? I don’t remember having this much trouble when I first installed Comodo a few years ago and the prospect of really messing up my system really makes me nervous.

Oh, one more thing…

During the last attempt I was offered 3 options for configuration: one plain and 2 that involved something called “proactive”. I picked plain. I was also offered the use of things called DNS servers. I chose not to use them because I don’t know what they are. Is this sufficient firewall protection? My wife’s laptop shares a DNS connection through a 3Com wireless router with the router’s firewall enabled.


This is only to make sure CIS is Removed< After Uninstall from Add/Remove does not work
You should be able to open up the zip folder by double clicking the zip file…
and simply drag out the “CIS Clean-up Tool”

Yes the File name will be CIS Clean-Up Tool
It will not say instructions

You do not have to boot in safe mode but its recommended!

As to your last question,
Plain/ Firewall Only disables Defense+ and will only have a firewall.
Proactive Defense is Defense+

Yes Its Sufficient ‘Firewall Protection’

You should be good to go.

Hope this helps


Am I to understand that it is sufficient that I remove the existing firewall through Add/Remove? If I run the built-in uninstaller and the Comodo icons disappear from my system, I do not need to use Revo or the CIS clean-up tool? That anything left in the registry will do no harm and that I can try to install the new firewall without further clean-up after Add/Remove has removed what it will?

Is it sufficient to go into safe mode just to do the installation of the new version after I have used Add/Remove if I do not need to use the CIS clean up tool.

What about the restart I’ve been told to do after installing the new version…shall I be sure to do it?

Correct. This is the recommended method of uninstallation.

If I run the built-in uninstaller and the Comodo icons disappear from my system, I do not need to use Revo or the CIS clean-up tool? That anything left in the registry will do no harm and that I can try to install the new firewall without further clean-up after Add/Remove has removed what it will?
Correct - any leftovers are benign. I would STRONGLY recommended that you follow all the instructions during hte uninstallation, particularly any REBOOT requests. You MUST reboot. Yes, it adds a couple of minutes to the overall process - big deal - what's one or two minutes in the big scheme of things?
Is it sufficient to go into safe mode just to do the installation of the new version after I have used Add/Remove if I do not need to use the CIS clean up tool.

I have never had any issues installing or uninstalling in normal mode. I recommend doing uninstalls in normal mode whenever possible.
What about the restart I’ve been told to do after installing the new version…shall I be sure to do it?
If it wasn’t necessary, they wouldn’t tell you to do it. :wink: Just reboot at the end.

Ewen :slight_smile:

Adding to Panic’s reply you can try the following procedure if the installation goes astray:

  • Uninstall CIS from Add/Remove programs
  • reboot when asked
  • boot in Windows Safe Mode. When you don’t know how to do so read http://www.computerhope.com/issues/chsafe.htm
  • run the clean up tool Jacob pointed at
  • when done boot back in the regular Windows mode
    Normally this should be enough. Now try installing again

Let us know if that does the trick for you or not. If it stays problematic we will continue from here.

You will NOT do that unless you’re nuts.

Work with these other guys to finger out the issue. They will help you…

Thank you all, so far!

Please don’t delete this thread or bury it.

I want to come back to you when I can try another installation.

No worries. Just book mark the topic so you can jump back in when you’re ready.

Ewen :slight_smile:

This is becoming a very discouraging exercise. Here’s what happened:

I used Add/Remove to remove the old version of the firewall. The uninstall was reported successful and I rebooted.

I opened the file containing the new version of the firewall and ran it. I allowed the installation to proceed using all the default options. The installation was reported successful. I rebooted and opened the GUI via the icon in the system tray and the firewall reported itself as running normally with everything in “Safe” mode.

That’s when trouble began. I clicked the “Firewall” tab to begin to explore and the GUI froze. I opened the task manager and it reported Comodo as “Not Responding”. I tried to “End Task” but that had no effect.

I left the computer on its own for 15 minutes to see if it would clear itself. It did not. I could minimize the UI but not do anything else so I used the only option I felt I had remaining and reset the computer.

When I restarted, it appeared that everything was back to normal. I opened the GUI as before and could move around from tab to tab. I closed the GUI and clicked my browser icon on the desktop to open it. The icon was highlighted but the browser did not open. In fact, NOTHING on the desktop would open and neither would the Comodo GUI via the systray icon. I opened the Start menu with the intention of uninstalling Comodo but I could not open Add/Remove, CCleaner or Absolute Uninstaller, any of which would have given me access to uninstall Comodo, and I could not close the Start menu once it was opened.

I rebooted the system into safe mode. Even though I could open Add/Remove I was not able to uninstall Comodo in safe mode. A message explained that the uninstall function would not work because I was in safe mode.

I decided to remain in safe mode and restore the system to the same configuration I used last time I tried an unsuccessful install of Comodo. I was able to eventually return the system to a previous working configuration but I am very concerned that this continuing resetting and restoring will destabilize my OS and cause me even more grief.

The GUI I now see for the “Summary” tab is from the old version although the background is now gray, not white and the notifications that appear in the bottom right of the screen are definitely from the new version even though it has been uninstalled.

This should not be this difficult!

May be left overs of previously uninstalled security programs are acting up. Try using removal tools for those programs. Here is a list of removal tools for common av programs: ESET Knowledgebase .

Otherwise do a Google search with terms “removal tool” and * name of product or vendor*.

I’ve run the online version of a couple of the tools on the list but the only tool I’ve had to uninstall is the 3.x version of Comodo FW. There shouldn’t be any remains of them in my registry. Comodo amd Avast are all this computer have ever seen.

The file I’m using to try to install the new firewall came directly from the Comodo web site as “cfw_installer_x86”.

I’ve run the same installation procedure I described earlier with the addition of running the CIS Clean-up tool in safe mode on the reboot after uninstalling version 3.x using Add/Remove. I then rebooted into normal operation and ran the clean-up tool again from a different file download, installed v 4.x and rebooted. The result is the same: GUI freezes, none of the desktop icons open their targets; there is no activity from the HD. Comodo reports green: all systems normal. Have done a restore back to version 3.x.

Do you have programs installed that interfere with networking like VPN program, Net Limiter, Peerblock/Peer Guardian…

No, nothing like that. My wife shares my printer through a wireless router and I have allowed access to and from her laptop during both attempts at installation.

Are you using a non standard theme in CIS? If so please try to return to the standard theme to see if that helps or not.

Did you change the way Windows looks by using a tool like Windows Blinds? If you did please undo these changes and see if that helps or not.