Need Latest ISO For Rescue Disk Creation


Please provide a link for the latest rescue disk ISO. I followed the instructions from this page:

I tried many times by selecting either the CD drive and USB drive option. It appears to download the ISO and ends up with an error message each time. I tried downloading an ISO (comodo_rescue_disk_2.0.261647.1), but I later discovered the ISO was dated to 2012. Of all the forum posts asking for help with a rescue disk that I looked at, there were no responses to the initial post.

My reason for going here, is I used the “clean endpoint” option recently, which opens up Comodo Cleaning Essentials. I ran a scan of my main hard drive over night and there appeared to be some undiscovered malware on the system, among other things, rootkits were listed. When I proceeded to have CCE remove or quarantine what it found, it crashed and disappeared off the screen. I am using Windows 10 Pro 1809. For the scan I was running CIS I just installed CIS over top of it but I still get the error when trying to create the rescue disk. I’m thinking there may be malware interference at work. If I can download the latest ISO for a rescue disk, I can reboot from the disk and deal with the malware that way. Of course, any better solutions are always welcome.


Try running a Windows Defender Offline/Pre-Boot scan see if it finds anything.

Hi CommodoUser2019,

Please check your inbox and provide the log details to investigate.

Mathi R

Hi CommodoUser2019,

Thanks for providing the requested logs. Our developers are working on it.

The latest CRD can be found at this link: as the one you get through CIS is I think version 1.x something I raised an issue about that hasn’t been fixed yet.

Hi futuretech,

Thanks for the link. Unfortunately, that ISO seems to be dated back to 2013. The other one I found, dated 2012, had no provision for wireless networking (preventing it from pulling latest updates), like Windows safe mode includes.

Yes it is an abandoned product so the latest is from 2013, as for wireless I think this one does allow connecting to a wireless network.

I was able to utilize the ISO last night. The wireless network portion was there but seemed to require a tech to setup so I found a very old, very long Cat5 cable and was able to update one database, but for some reason, the signature definition update failed. Tried a few times. Perhaps there is no longer any provision for updates on that part.

Secondly, I should add that my interest in this product is not due to any malware that Comodo might have let slip by. I only put CIS on my PC a few months ago and it’s been a while since the OS has been refreshed. If there is any malware, spyware or PUPs on it, it’s from before I started using Comodo.