need help updating!

Hey there Comodo peeps!
let me say i really love your free internet security product, i give it a two thumbs up! :smiley:

but for some reason it wont let me update the virus signatures. it keeps saying unable to update, even if i try it manually or automatically. I am running the x64 bit version of CIS. If you can help me that would be really appreciated, i want to get my comodo updated and running to its fullest potential! Thanks!
aristizzle dawg! :stuck_out_tongue:

What virus database version does it say is installed?

it doesnt have any virus update installed. since i installed the program ive been having the same problem as a bunch of other people, it starts to update but then stalls at 30%. ive tried a manual update, nothing, ive tried an auto update, nothing. i dont know what to do. any suggestions?

What version of CIS are you running?

i’m facing the same problem too…stucked at 30%…CIS is really bad in update…please rectify it…i’m using the latest ones…

After a fresh install of CIS there is a big download for the AV database with approx size 34 MB. During that process the progress indicator will stay at 30% for a considerable amount time. This confuses many people. When the update speed is slow it seems to take forever.

How are things now?

well im trying to update it, it still is stuck at 30% though. Honestly, I deleted Comodo a couple weeks back when I was having this problem because I just didn’t like the fact that it wasn’t updating, but I couldn’t hold myself back from re-downloading it, so here I am stuck again at 30%. Everytime it tries to update it says update failed. I don’t know what to do anymore. I have read through these forums like crazy looking for a solution. If anyone can help me, it would be greatly appreciated. I will keep trying to update but I don’t know why it’s not letting me.

im running Vista x64 bit version.

After installing CIS it will have to download approx 40 MB of AV updates. During this process the progress indicator will stay at 30 % for a long time. In the case the download of the update is slow, being on dial up for example, it will stay at 30% even longer.

Please be patient with it. Sorry I have no better news for you.


After clean-install the AV-updater took a break at 30% at mine too.
Just look at your Network-Traffic-Monitor (ComodoOverview-GUI) there you should find a process called updatemanager or something like that and this one should still receiving data. So you see it is still working.
I guess I updated in time with many others so I took 1 hour to complete.