Need help badly with ports in firewall

Ok so I updated to the new Comodo Internet Security Suite, now my winmx won’t connect on primary. >:( I cannot locate any guides for the new comodo suite on how to open or allow the ports via the firewall… HELP!!! I was able to do this with the older version of Comodo (there where actually guides [at] for this) I’m so ready to go back to my old Comodo at this point. Any help would be GREATLY appreciated… tysvm

May be these pages can be of help for you:

Let us know how things go.

Thanks for replying :slight_smile:

I followed the instructions to the tee at the following link:

It still not working, when I try to use a primary connection on winmx I now get a You cannot make a primary connection to the winmx peer network for the following reason: No UDP port for incoming and outgoing packets :cry:

Ewwwwwwwwww and just noticed that after I went back into Comodo all the rules I added are gone?!! sighhh

Thoughts or solutions???

Update to last post:
WinMx finally connected on primary, but something still wrong >:( . At the top bar I am showing P=7 S=0… From what I have read that indicates a port is closed… The issue is not within my router, all that has been forwarded, my speedstream router router/modem functions soley as a modem… This problem with primary connection has only come about since installing the Comodo Internet Security Suite. … So somewhere within the firewall it is still not allowing my primary connection to work correctly… Thanks for any help/advice ya’ll can offer :slight_smile:

I am not familiar with the specifics of Winmx. What ports need to be opened for it to work successfully?

Can you show me a screenshot of your global rules? What rules et are you using for Winmx? When using custom rules post a screenshot of them as well.

Hey EricJH,

The ports that I need to work for winmx are:
Incoming TCP connections port: 50100
In/Out UDP packets port: 55000

Here are the screenshots:
WinMX Rules:

Global Rules:

Thanks so much for helping EricJH…

I think I see the problem. There are no global rules yet for the incoming traffic of Winmx.

Now add the following rules to open the Winmx ports; choose and then fill in:
Action: allow
Protocol: TCP
Direction: in
Description: TCP rule for Winmx

Source address: any
Destination address: you have choices here. use your local IP address when that is a fixed one. MAC address is a solid one.
Source Port: any
Destination port: 50100

Now do the same thing for the UDP rule. When done make sure both rules are somewhere above the basic block rule (the red rule at the bottom).

Now it should work I think.