need help badly!!!...CAN'T START FIREFOX with Comodo Firewall & D+ [RESOLVED]


I’ve searched the forum and saw some solutions by Vettetech and I tried it, Firefox still doesn’t open. The only time Firefox opens is when D+ is in Disabled Mode.

This is what I get when I try to open it.

C:\Program Files\Mozilla FireFox\firefox.exe

“Windows cannot access the specified device, path, or file. You may not have the appropriate permissions to access the item”

Under Firewall Tab, I set Firefox using Network Security Policy as a Web Browser and under D+ tab, (Computer Security Policy) I tried setting it as a (Predefined Policy) Trusted Application and also Custom Policy. STILL NO LUCK! I just installed Comodo too.

Internet Explorer opens up just fine, but I don’t like IE, I rather use FireFox. Is there anyone that have experience this problem? Any help would be greatly appreciate it. Can someone type out step by step what I can do. Thank you.


Why don’t you try putting D+ in training mode. It could be one of your extensions. Try disabling each one to see which one is causing the problem.

I’ve tried it in D+ Training Mode, all the way to Paranoid Mode. Only Disabled Mode works.

What do you mean by extensions?

Nevermind I’ve figured it out.

It was blocked in explorer.exe under Computer Security Policy DOH! haha Thanks anyway!!

(J) (:CLP)

Exactly that. What Firefox extensions are you using.

Glad you fixed it rickster555: I will mark this topic as resolved and close it. If you want it re-opened please PM a moderator.