My Trustconnect has stopped working

I have two issues that i need help with Trustconnect has stopped working on my computer windows firwall blocked Trustconnect saying it was a security issue becuase it was leaving a port open for attack but i unblocked it and it still wont work.

I have comodo firewall 2012 and trustconnect doesn’t connect with the firewall when im logged in to a public place or at home is there a way to fix that? would it be safer if i do it with comodo firewall?

If you disable Windows firewall and Comodo firewall - does TrustConnect work OK?

I just tried it and it couldn’t connect to the server

This shows up in the log if it helps
Mon Mar 04 19:44:52 2013 AUTH: Received AUTH_FAILED control message
Mon Mar 04 19:44:52 2013 SIGTERM[soft,auth-failure] received, process exiting

Probably, you entered incorrect password (please pay attention to register - symbols in uppercase are not allowed). Also, make sure that you’re not already connected with same credentials from another device.

yer that was the problem it’s up and running now thanks mate. i changed my password but trustconnect was still working after i changed my password so i forgot to change the password on trustconnect when i used it again.

I have another problem I’m using trustconnect on my Iphone but whenever i set it to send all traffic (On) none of my apps or browser can connect to the internet is there a way to fix this?

Are you sure that connection to TC has been successfully established? Maybe the connection is closed immediately after the connection?

Hey sorry for the late reply

I’m still having the same problem I’ve tried it several times now and connection is established every time

I’d recommend you to contact the support: (please, don’t forget to provide them your service login).

Alright thanks for you help I’ll give them a go