My odissey with CIS

For months, no COMODO software has worked on my system with the exception of BOClean and the Memory Firewal. Well, I say that they worked but I am not sure anyway. At least, they didn’t bother me at all.

Now I will tell my disgrace with CIS. As the version that was released before the one of December 2008 didn’t work on my rig (Windows Vista SP1 64 bits), I had abandoned all hopes to use CIS. Anyway, in December I tried with the new version. Despite I am an experienced user (webmaster with fifteen years of experience), after installing CIS at that time I just couldn’t surf the Web!! My connection was OK, but no web surfing was possible. I had taken the trouble to uninstall everything that could interfere with CIS (Avira, etc.) but I had to quit after days full of frustration (even the Comodo support couldn’t find a solution for my problem).

Well, right now I learnt that a brand new version had been released and the voice inside me told me “Don’t touch CIS even with a long pole!”. Still, I downloaded and installed it after having removed Avira and Webroot Desktop Firewall completely (I disabled all their services too, of course). Oooops, I was absolutely speechless at what I experienced: no browser ran (Firefox, IE 7, Google Chrome, etc.) so no navigation was possible. But even worse, no mail software didn’t work either. And surprisingly the Catalyst Control Center of my Radeon 4870 wasn’t loaded at the startup. I had to make it run manually and I noticed that the card was hotter than usual (about 10° C). Besides, the hard drive continued to work so much that the performance of my PC came down drastically.

Of course, I tried many things: e.g. disabling the Proactive Defense, etc., but nothing worked out! At last, I decided to uninstall it. Anyway, I allowed the Comodo service to load after the restart and despite CIS had been uninstalled fully, the problems with my PC continued. So, I disabled that Comodo service, restarted the machine and voilá, my problems were off! I had to enable Avira and Webroot Desktop Firewall again, obviously. And the temperature of my Radeon looked normal again to my massive relief.

OK, I arrived at this conclusion: there is something nasty going on between that Comodo service and my Windows Vista SP1 64 bits. I keep it updated and in a good shape since I am an advanced user, but no way with CIS!! The worst part of this mess is that CIS looks so good in comparison to Webroot Desktop Firewall and Avira. But, I cannot waste my time with those crazy things CIS does on my machine. On the positive, I can say that the last crazy events with CIS were at least pretty different from the former ones. Before I could use a browser but not surf the Web. Now, I can’t even use a brower, my HD is driven crazy and my Radeon behaves anomalously!! That’s got to be a funny thing, right? :■■■■

If someone had the same experience as myself and found a solution, please, share it with me. Thanks in advance!

BTW: I didn’t want to say this before on the forum because CIS is freeware, you know. Nevertheless, the things CIS did on my rig today were too much (nuts really!) and I couldn’t help tell you about them. I want to use CIS with all my heart, but the devs will have to polish some things in future versions, I guess.

Evening & Welcome To The Greatest Place On Earth :stuck_out_tongue: Just Kiddin ya, but Welcome To Comodo Forums.

It Seems to me that you had a pretty hard time with CIS.

Ok, Just to double check your issue’s:

  1. You Don’t Have CIS Installed; Correct?
  2. You Cannot Browse The Web But You Have Web Connection (What type dial-up/cable/T1); Correct?

Partial Solutions (As in might not work, AKA The First “Wack At It”) (Have you tried)

  1. System Restore(Last Partial Option)
  2. Remove CIS (Safe Mode after that Run A Registry Clean)
  3. Disable Network Connections Then Enable After 15+ Seconds
  • Jacob

Now Comodo is working fine. I read on another thread that the issue was related to having Ad-aware also installed on the machine. I uninstalled Ad-adware and that’s it!

Really, it is difficult for a non-developer mind to imagine that two programs in conflict can bring about such a tremendous debacle even with the videocard!

Thanks for your support.

Glad to hear it works now, hope you now can now start enjoying using it (:WIN)

Personally, I see this as no small thing. Comodo and Ad-Aware don’t do the same thing. And even if they did, everyone who’s serious about keeping exploits off their system knows that having more than one tool makes good sense (though one should never have more than one real-time (constantly-monitoring, runs in the system tray) type tool for each exploit type).

Most thinking IT professionals have something like CIS; plus, at the very least, free SuperAntiSpyware and free Malware Bytes. I, personally, also have Spybot Search & Destroy and Spyware Blaster.

Until I researched it and found that a-Squared-Free missed tons of things which the foregoing products all caught, I had that on my machine, too.

I let CIS’s three components do their thing in realtime; and I use both Spybot S&D’s and Spyware Blaster’s innoculation capabilities; and I use Spybot S&D’s HOST file and its IE helper capability (but not its TeaTimer); and I let free SuperAntiSpyware sit in my system tray watching for changes to my home page (which I used to, but no longer, let Spyware Guard do); and then I use them all to periodically manually scan (except for Spyware Blaster, which doesn’t do that).

I don’t have Ad-Aware on my machine because… but not because it conflicts with CIS. I abandoned it a while back because it has become a piece of ■■■■ in its later years… a mere shadow of its former self… and is no longer well-behaved and minutely controllable. Plus, it catches nothing which the others – either individually or together – don’t already catch.

But if Ad-Aware were still the product it used to be, I’d have it on my machine as well… not as a real-time monitor in the system tray, mind you, but at least as an occasional manual scanning tool… the way I use the other aforementioned non-CIS (and non-Spybot-IE-helper or Spyware Blaster) tools.

However, others may not share – and should be free not to share – my perspective; and may wish to have Ad Aware on their machines. Since I’m unaware of Ad-Aware being particularly troublesome when used on the same machine as CIS’s competitors, I see this as like to be a CIS problem… and no trivial one, at that.

Or so it is my opinion.

Comodo, I hope, is seriously investigating (and, if found to be culpable, remediating) it.