My CIS v4 Experience

I installed CIS 4 a few days after it was initially released and was very happy with it.
Everything worked fine, it gave a few popups and then it ran completely silent.

Unfortunately, it ran silent because the D+ Component didn’t work at all. When I looked at the Policy List, only 3 Programs where listed inside, and I tried to configure D+ so that it would give alerts for everything that happened. I disabled the Sandbox and still D+ didn’t do anything.

When the Sandbox was enabled, the Sandbox stopped working after a few hours and i found out that CIS always contained Errors. After fixing them with the integrated Diagnostics Tool and rebooting, it workend for half an hour until CIS was again damaged.

Sadly, after a few attempts to fix it, Programs stopped working, for example Firefox didn’t run at all, even after unloading CIS and rebooting.
I restored my System with System Restore and tried again, but CIS 4 always did the same errors even after reinstalling.

So I gave up using it and switched back to Version 3.14.

I really liked CIS 4 but this strange behaviour just made me feel unsecure because I could run every Program and CIS didn’t ask anything. I wrote a small Program which uses common techniques(like TerminateProcess() of the Windows API) to terminate a Process and terminated some successfully. CIS wasn’t bothered at all by it and didn’t even ask.

It was set to Proactive and D+ on Paranoid with Image Execution on Aggressive for all executables. Sandbox was disabled and I also tested it with Enabled. Nothing changed, everything was allowed.

Funnily, right after a fresh CIS Install, everything worked correctly, Sandbox did its job just fine, D+ intercepted Processes before they could do anything, Firewall asked for Connection Attemps… but after an hour or more, it just went silent and did nothing.

My System is Windows XP with SP3 installed, I use no other realtime Security Application besides CIS 4 (or now: CIS 3.14). Drivers are the latest available and the System is in top Shape and no evidence of malware.

So I’m not sure why CIS 4 doesn’t work. But the period it worked it just did fine and kept everything safe.
I’ll switch back to CIS 4 once a new update comes out.

this happened to me to. i repaired cis with a reinstall

I reinstalled it 4 times and it didn’t work. I also used the Diagnostics Utility and it didn’t work.

did you try a clean install? download revo uninstaller and use it set to moderate to remove CIS, then reinstall.

I use Revo Uninstaller for every Program I uninstall.

And yes, I uninstalled CIS with it and cleaned up. Also with Comodo System Cleaner.

Lunz- Have you used the Comodo Cleanup Tool ?

This is a batch file for removing left-over files and registry entries. It should only be used if:

  • You can’t uninstall Comodo Internet Security
  • You can’t install Comodo Internet Security
  • Comodo Internet Security is already uninstalled, and you want to make sure everything’s gone


I used it too, but that didn’t improve the Result.

Also Comodo was successfully installed or uninstalled, but it simply stopped working correctly after a short time.

I’ll wait for Version 4.1 to try, hope this solves the issue.

I hope that v4.1 works well for you. From the look of languy99’s video CIS v4.1 is a great improvement over v4.0…


Yea and the biggest issue with sandbox seems to be fixed with that Sandbox Button :slight_smile:

That will solve the crashing with code compilation :slight_smile:

This is my " default " setting for CIs 4 - and for the previous naturally - since the post-installation reboot, and CIS 4 run perfectly.