MSVCR71.dll missing

Hi, can any one help me restore MSVCR71.dll?? I keep getting prompts telling me that its missing or

corrupt and reinstalling should fix the problem only it fails to explain how to go about this!

I’ve installed a few Reg cleaners/fixers none of which fixes this problem…any help PLEASE?

I don’t know if it will help or not, but a friend of mine uses this site for most of his dll problems.


Look up a mscvcr71.dll on your system and copy it to the CSC installation folder or when that doesn’t help to system32 folder. Those are the usual tricks I think.

Hi Celtman,

MSVCR71.dll is a Microsoft® C Runtime Library current version is 7.10.3052.4

… but you did not provide any info about the system you are using.
You are getting message from what Software?

The said Library is supplied by many vendors. In most cases they will place it into the base directory of the Software

I have 51 instances of it here (see attachment)

It is important to know who is claiming the library.
It may be necessary to obtain the particular one from the vendor (details about “why?” could be extensive & annoying)

You may need to re-register the library , but for that it is necessary to know what was pointed above
That is not obvious (despite “it may work” … that placing the one into \system32\ will be the right thing to do.

Finally please do not rush to use any “dll downloading sites” as suggested unless you find out what is needed.
In many cases you will be fine wit the system MS dll and getting it from them or recovering from the MS CD
even running SFC Tool in the 1st place can give some answers & help Read about it here

My regards

[attachment deleted by admin]

Thanks for the advice, I’m afraid I’m outta my depth here… you mentioned the SFC tool Siberlynx, but I’m not sure how to run that even?!!

My System is

Computer Profile Summary
Computer Name: (in WORKGROUP)
Profile Date: 30 March 2010 22:53:53
Advisor Version: 8.1k

Operating System System Model
Windows XP Home Edition Service Pack 3 (build 2600)
Install Language: English (United States)
System Locale: English (United Kingdom) Time Computers MS-6712 1.0
Processor a Main Circuit Board b
2.10 gigahertz AMD Athlon XP
128 kilobyte primary memory cache
256 kilobyte secondary memory cache
Not hyper-threaded Board: MSI MS-6712 1.0
Bus Clock: 170 megahertz
BIOS: American Megatrends Inc. Version 07.00T 04/02/01
Drives Memory Modules c,d
118.33 Gigabytes Usable Hard Drive Capacity
84.47 Gigabytes Hard Drive Free Space

DVD-16X DVD-ROM BDV316C [CD-ROM drive]
MSI CD-RW MS-8348 [CD-ROM drive]
3.5" format removeable media [Floppy drive]

IN-WIN iAPP HS-CF USB Device [Hard drive] – drive 1
IN-WIN iAPP HS-MS USB Device [Hard drive] – drive 2
IN-WIN iAPP HS-SD/MMC USB Device [Hard drive] – drive 4
IN-WIN iAPP HS-SM USB Device [Hard drive] – drive 3
ST3120023A [Hard drive] (118.36 GB) – drive 0, s/n 3KA0WZFJ, rev 3.95, SMART Status: Healthy 1024 Megabytes Usable Installed Memory

Pops ups from Zonealarm frequently set it off, as did the box that appeared after I ran “winver”.

Thanks again for any advice

Thanks for reply, Celtman

I am sure that will not bring something new and make it clearer if I would repeat what’s written in MS article about running SFC as in the referred thread.

The only thing that I may assume from your description - it’s most likely the “main” registered MSVCR71.dll in the \system32\ folder that got corrupted (or other reasons)
My speculation based on your statement that running “winver” causes the error being displayed
I am not sure about what you said when mentioned ZoneAlarm(ZA) - that is not clear description at least for me

At this stage I may suggest the following:

  • disconnect;
  • properly disable ZA;
  • since you are disconnected you can disable any other security in place;
  • Reboot;
  • run SFC as described (that may take some time)

Post the result and/or any messages it produced or just follow its advice if it will find something wrong regarding the component in question


p.s. I don’t know or rather I do not understand this advice by Eric:

  • 1st there is a misspelling of the file compare to what you posted
  • I have no idea why CSC was mentioned (Comodo System Cleaner ???) and whether the latter is using the said library ??? It probably does … but what’s the relevance?
    In addition - my opinion using CSC :o - God forbid ! :-TD anybody doing that!
    how many “Brave Hearts” are out there ? Good luck!

Hi SiberLynx… sorry for delay, tried running sfc and after about 10 mins or so and the progress bar ended, it just disappeared, the whole box I mean and no results were displayed??

Whats going on??! Do I have a virus aswell do you think?

PS Ran sfc several times just to check, same result each time.

Also in regard to ZoneAlarm setting off the MSVCR71.dll missing dialouge, if I CTRL ALT + DEL it’ll appear too.