MPC losing focus due to updates

Hi, First I’d like to say thankyou to all involved with the running and maintenance of all comodo products. I am currently using the firewall and am very impressed with the level of security offered by a free program.

My problem is this, whilst playing video using Media Player Classic (off line) focus is lost quite frequently due to comodo’s automatic updater. I’ve tried turning learn component off but i still get the problem. I’ve done some googling and FAQ checking but i haven’t come up with anything that specifically deals with this problem. It doesn’t happen with VLC but i prefer MPC and dont want to stop using it. Any help would be greatly appreciated.

Thankyou for you time

archer23 - welcome to the forum.

I also use MPC from time to time, but never use auto-updater (for any program), so I never encounter your issue. One thing I do know is CFP’s Component Monitor shouldn’t cause MPC to lose focus. BTW, Component Monitor and the CFP Updater are 2 different items.

What if you enabled MPC’s option in View menu > On Top > Always (or press Ctrl + T)?

I’ve been having the same problem. My full screen videos in MPC will lose focus to the auto updater. I’d set it to “Always on top” and test it, but there is no way to know when the firewall will update so I couldn’t really. Not really that big of a problem, but an annoyance nonetheless.

Next time i loose focus in MPC i’ll post the exact reason why on this forum (stated by MPC). It may be a while before i watch anything though. There is definitely an issue with MPC loosing focus but there are other applications that can cause it.
I’m offline when i’m watching movies so i 99 percent sure the focus loss is due to comodo learning about MPC through component monitor and then updating the appropriate file, the resulting cpu use required for the update causes MPC to loose focus.
Surley if i could completely disable comodo when i’m off line this should solve any focus loss issues, how can i disable all update and learning functions to test this? Is it as simple as turning the component monitor “learning” setting to off, or do i need to configure some advanced settings as well?

Thanks in advance Soya

I just got the message “Error 106 Could not complete update process” when trying to update comodo through the application whats with this?

I still find it strange that Component Monitor is the culprit, but it indeed consumes some cpu every 10 minutes (?) while in Learn Mode. You can turn if Off when you’re not on the net and switch it back to Learn when you want.

The CFP Updater, on the other hand, has received a second testimony by sam82. This I suspect is more like the culprit. And to disable it go to Security > Advanced > Miscellaneous > Configure > disable the first to auto options.

Frankly, I recommend that users disable it because the next update won’t be until version 3 comes out. And even then, I will uninstall CFP 2 and install 3 instead of installing over top to avoid potential issues (they have different architectures).