Mozila Thunderbird - Comodo Firewall problem

So here’s about the problem:

The software I have installed:
Windows 7 x64, up-to-date
Mozial Thunderbird 3.0.3 with an IMAP account, properly configured
Comodo Firewall + Defense modules, v4

Now, the prolem is that I can’t send emails to anyone, not even myself. Whenever I compose a message and click send I wait a while and a timed out error appears. This problem only manifests itself while sending messages. I can receive emails perfectly.

I’ve also put an Email rule for Thunderbird in the network security policy but nothing changed. I also tried the things posted on this topic but still no luck.

Any further suggestions?

Can you show screenshots of Global Rules, and the firewall logs?

Global Rules can be found under Firewall → Advanced → Network Security Policy.
The firewall logs can be found under Firewall → Common Tasks → View Firewall Events.

Here they are:

[attachment deleted by admin]

I only see alerts for outgoing on port 80. That is the usual behaviour when an email loads images from a server on the web. As part of the E Mail client policy you will be asked if you want to allow that or not.

IMAP traffic is handled at port 143 (TCP and UCP). Do you see alerts for them in the logs? I checked the email client policy and it doesn’t provide a rule for IMAP.

May be you can add the following rule to the T-bird client rule :

Action: Allow
Protocol: TCP and UDP
Direction: Out
Description: Allow IMAP

Source Address: Any
Destination Address Any
Source Port: Any
Destination Port 143
When done editing the rule make sure it is above the Ask rule at the bottom.

Yes, those alerts I did allow. They occured more than once because I deleted the policy a few times. Other than those, I have no other firewall events related to Thunderbird.

I tried adding the port 143 rule, but still no go. :frowning:

HI,The problem could be in Thunderbird.Under tools/ Check account/ outgoing service SMTP/edit/see if security is on SSL/TLS which change the outgoing port to 465. Most ISPs or e-mail servers don’t support this setting. Change to STARTLS which is just as secure. The port will switch to 25 click OK and everything will be OK. I’ve seen some that don’t support any security and you have to select none. Check incoming to match in account settings. Hope this helps.

That worked! ;D
Thanks, much appreciated.