Mouse scroll not working in contained windows [M2354]

A. THE BUG/ISSUE (Varies from issue to issue)
Can you reproduce the problem & if so how reliably?:
If you can, exact steps to reproduce. If not, exactly what you did & what happened:
1:Run application in contained window. Attempt to scroll using touchpad

One or two sentences explaining what actually happened:
Mouse scrolling shows the scroll icon however no actual scrolling happens

One or two sentences explaining what you expected to happen:
Expect scroll action to take place. Like scrolling webpages, scroll zooming in apps, scrolling lists in other apps.

If a software compatibility problem have you tried the advice to make programs work with CIS?:
Seems to be affecting all applications

Any software except CIS/OS involved? If so - name, & exact version:
Synaptic pointing device drivers
Any other information, eg your guess at the cause, how you tried to fix it etc:
Issue seems to be with Synaptic. I’ve connected a USB mouse and scroll works fine in contained window. Interestingly, after attempting scroll with touchpad, the USB mouse scroll stops working until I click in the window. Seems touchpad scroll is taking focus away from active window when utilizing containers.

Exact CIS version & configuration:
All but HIP enabled

Modules enabled & level. D+/HIPS, Autosandbox/BBlocker, Firewall, & AV:
Anti-Virus stateful
Auto-Containment Enabled
HIPS disabled
VirusScope Enabled
Firewall Safemode

Have you made any other changes to the default config? (egs here.):

Have you updated (without uninstall) from CIS 5, 6 or 7?:
No. This is first time install
if so, have you tried a a a clean reinstall - if not please do?:
Have you imported a config from a previous version of CIS:
if so, have you tried a standard config - if not please do:
OS version, SP, 32/64 bit, UAC setting, account type, V.Machine used:
Win 7 Ultimate SP1, UAC default (Enabled), V. Machine? Virtual? This is Dell L702X laptop. Comodo installed on host. Have not experimented with VM’s yet. Do have VirtualBox, VMWare installed however do not think this is a factor.

Other security/s’box software a) currently installed b) installed since OS, including initial trial security software included with system:
Nothing else running

Side note: I also run Windows with unprivileged user for additional security. However, I also confirmed issue is unchanged on admin account.

Thanks, team will check.

Should add Synaptic version.
Synaptics TouchPad V7.4
Synaptics Pointing Device v15.3.22 25Aug11
This appears to be latest driver available. Windows update claims up to date for this driver, Dell site has older driver for this laptop, Synaptics does not seem to list drivers on their site.

Interesting I used to have a laptop with a synaptics touchpad and I don’t remember having this issue, can you check HIPS events to see any blocking related to synaptics applications or files? Make sure you use no filtering under filter by date & time.

HIPS is disabled and I see no entries for Synaptic. Closest match is the Dell QuickSet which does have a off/on switch function and was scanned and found to be trusted. After gaining a little more experience with this Comodo solution, I think this is very much the same sort of separation between host and containers treatment as the copy/paste function. Synaptic ends up running on the host but cannot interact with the contained windows for scrolling. Not sure how to go about proving this however so for now just a thesis. =(

Please check issue again with Comodo Internet Security v10.2.0.6514 thanks.

Just finished installing. Still experiencing all the same behaviors.

I would like to know if you recently just discovered this or if it used to work before but now no longer works. Also can you attach the CIS diagnostic report and system information output using msinfo32. Thanks, I have submitted the bug into the internal tracker for comodo to investigate.

Also can you try to add notepad to shellcode injection exclusion, then run notepad in containment, then hold enter key long enough to create a scroll bar, then see if you can use mouse scroll on the touchpad.

Please check issue again with Comodo Internet Security v11.0.0.6574 - BETA thanks.

Sorry for lack of responses here. I have just not been running anything in container which is too bad as thats one security layer not being used. And when i do, i’ve just been using a mouse rather then using touchpad which can get ugly if the laptop is actually on my lap. =(

anyway, even today with latest version the issue continues.

Issue has been at play since day 1. I started posting on this forum shortly after I first installed as I was testing.

msinfo32 input device info:
Hardware Type Synaptics PS/2 Port TouchPad
Number of Buttons 0
Status OK
PNP Device ID ACPI\DLL0570\4&2F4C41A&0
Power Management Supported No
Double Click Threshold Not Available
Handedness Not Available
IRQ Channel IRQ 12
Driver c:\windows\system32\drivers\i8042prt.sys (6.1.7600.16385, 103.00 KB (105,472 bytes), 7/13/2009 7:19 PM)

After notepad suggestion below, I’ve learned that notepad, notepad++ (and maybe other apps) work fine. The browsers in Comodo menu (Dragon,FireFox,Chrome) all fail the scroll test. However IE in that same comodo menu works fine.

have not run diagnostic report. I’ll need to set aside some time and circle back to that so I can sift through it to make sure no sensitive info is getting placed in public domain. =)